View Issue Details

IDProjectCategoryView StatusLast Update
0000974FreeCADBugpublic2015-01-02 14:22
ReporterjdbrandmeyerAssigned To 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Product Version0.12 
Target VersionFixed in Version0.15 
Summary0000974: Lock-up during Polar Pattern transformation
DescriptionSelect the pocket in this file. Use the polar pattern tool, and type 36 occurrences. Lockup.
Additional InformationHost is Windows 7 64-bit. Application is 32-bit.
OS: Windows 7
Platform: 32-bit
Version: 0.13.1828
Python version: 2.6.2
Qt version: 4.5.2
Coin version: 3.1.0
SoQt version: 1.4.1
OCC version: 6.3.0
TagsNo tags attached.

Relationships

related to 0000977 closed Slow performance when transforming a pattern 

Activities

2013-02-05 02:10

 

statorfull.FCStd (Attachment missing)

jdbrandmeyer

2013-02-05 02:28

reporter   ~0002884

This issue can be downgraded somewhat. The root cause was that the sketch which was the basis of the pocket was not totally enclosed. However, even after correcting that issue it takes ~1 min on a fast overclocked 4GHz processor to complete the polar pattern.

wmayer

2015-01-02 14:22

administrator   ~0005485

Confirmed for 0.13 but works for 0.15. There it takes ~5 sec.

OS: Windows 7
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.15.4386 (Git)
Branch: master
Hash: c4fb8fc8ae753c20714eb944527fb5f963969b2f
Python version: 2.7.6
Qt version: 4.8.5
Coin version: 4.0.0a
OCC version: 6.6.0

Issue History

Date Modified Username Field Change
2013-02-05 02:10 jdbrandmeyer New Issue
2013-02-05 02:10 jdbrandmeyer File Added: statorfull.FCStd
2013-02-05 02:28 jdbrandmeyer Note Added: 0002884
2013-02-21 06:13 jrheinlaender Relationship added child of 0000977
2015-01-02 14:09 wmayer Relationship deleted child of 0000977
2015-01-02 14:10 wmayer Relationship added related to 0000977
2015-01-02 14:22 wmayer Note Added: 0005485
2015-01-02 14:22 wmayer Status new => closed
2015-01-02 14:22 wmayer Resolution open => fixed
2015-01-02 14:22 wmayer Fixed in Version => 0.15