View Issue Details

IDProjectCategoryView StatusLast Update
0000973FreeCADBugpublic2013-09-03 12:00
ReporterjdbrandmeyerAssigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.12 
Target VersionFixed in Version0.14 
Summary0000973: Wrong outline in pocket
Description
The enclosed part contains a pocket that comes from Sketch001. However, the view of the pocket on the screen does not match the dimensions of the sketch. The radii of the two fillet-like corners in the +x direction are shown much too large compared to the sketch itself. If you open the sketch, the right curves are shown.
Additional InformationHost is Windows 7 64-bit. Application is 32-bit.
OS: Windows 7
Platform: 32-bit
Version: 0.13.1828
Python version: 2.6.2
Qt version: 4.5.2
Coin version: 3.1.0
SoQt version: 1.4.1
OCC version: 6.3.0
TagsNo tags attached.

Activities

2013-02-05 02:07

 

statorfull.FCStd (Attachment missing)

logari81

2013-02-14 20:32

developer   ~0002904

try reducing:

Edit-->Prefernces-->PartDesign-->Shape view-->Maximum deviation ...

if this is not what you mean, please upload a screenshot that illustrates the issue.

2013-03-02 15:06

 

Sketch_Of_Pocket.png (Attachment missing)

2013-03-02 15:07

 

Pocket_3D.png (Attachment missing)

jdbrandmeyer

2013-03-02 15:12

reporter   ~0002953

No, it isn't the granularity of the curve's rendered segments. It is the radius of the curve. Referring to Sketch_Of_Pocket.png, The outline of the resulting pocket is visible in black, the outline of the sketch itself in green. Note that the radius of the lines in the sketch has been set to 1.0. However, the shown radius in the pocket is closer to 2.0 or 3.0.

I suspect that this is a caching bug of some sort. The shown radius in the pocket represents an earlier state in the sketch as it was being constrained. The order of operations was:

Create sketch
Constrain sketch
Create pocket

normandc

2013-03-15 01:19

manager   ~0002983

Your slot profile is not closed. Reference geometry (magenta) and construction elements (blue) are discarded by Part Design features. Close your profile and the pocket updates correctly.

I'm surprised the pocket didn't fail completely, that's what the bug is IMO. It should warn the user that the feature cannot succeed because the profile is not closed.

wmayer

2013-09-03 12:00

administrator   ~0003539

Last edited: 2013-09-03 12:04

This bug is fixed because from the sketch we try to get a face which fails in this case now. So, FreeCAD won't let the user create a pad/pocket.

Issue History

Date Modified Username Field Change
2013-02-05 02:07 jdbrandmeyer New Issue
2013-02-05 02:07 jdbrandmeyer File Added: statorfull.FCStd
2013-02-14 20:32 logari81 Note Added: 0002904
2013-03-02 15:06 jdbrandmeyer File Added: Sketch_Of_Pocket.png
2013-03-02 15:07 jdbrandmeyer File Added: Pocket_3D.png
2013-03-02 15:12 jdbrandmeyer Note Added: 0002953
2013-03-15 01:19 normandc Note Added: 0002983
2013-09-03 12:00 wmayer Note Added: 0003539
2013-09-03 12:00 wmayer Status new => closed
2013-09-03 12:00 wmayer Resolution open => fixed
2013-09-03 12:00 wmayer Fixed in Version => 0.14
2013-09-03 12:01 wmayer Note Edited: 0003539
2013-09-03 12:04 wmayer Note Edited: 0003539