View Issue Details

IDProjectCategoryView StatusLast Update
0000959FreeCADBugpublic2013-03-23 15:13
Reporterbenjamin12345Assigned Toyorik 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version0.14 
Summary0000959: arc orientation sometimes becomes wrong when exporting to DXF
DescriptionWhen drawing arcs with sketcher and then exporting the sketch to DXF, the arc orientation sometimes becomes wrong. I have attached a zip-file with one fcstd-file and one dxf-file that illustrate this problem.

I have reported this once before and it was marked as fixed, but apparently it is not. Or maybe it is fixed in another git branch?
Additional InformationFreecad version: 0.13
Git revision: 1822
Git branch: master
OS: Ubuntu 12.10 64-bit
TagsNo tags attached.

Activities

2013-01-15 10:04

 

arc_bug.zip (Attachment missing)

daramarak

2013-02-11 08:27

reporter   ~0002893

This is also an issue in

Freecad version: 0.12
Revision: 5284
Date: 2011/12/12 21:03:10
OS: Windows 7 (32-bit)

I can add another sample if needed.

yorik

2013-02-14 21:06

administrator   ~0002908

I believe this is fixed in 0.13 but I?l check.

yorik

2013-02-16 21:16

administrator   ~0002912

Ok, this is another problem than before, the sketch-draft conversion works fine, but there is something wrong in the DXF export code.

yorik

2013-02-21 21:36

administrator   ~0002937

I did a fix (commit f66c433) that seems to fix the problem in all cases I could test. I'll leave this report open a bit more to see if someone still reports issues...

yorik

2013-03-23 15:13

administrator   ~0002999

Closed because no more feedback. Reopen if needed!

Issue History

Date Modified Username Field Change
2013-01-15 10:04 benjamin12345 New Issue
2013-01-15 10:04 benjamin12345 File Added: arc_bug.zip
2013-02-11 08:27 daramarak Note Added: 0002893
2013-02-14 21:05 yorik Status new => assigned
2013-02-14 21:05 yorik Assigned To => yorik
2013-02-14 21:06 yorik Note Added: 0002908
2013-02-16 21:16 yorik Note Added: 0002912
2013-02-16 23:36 yorik Severity major => minor
2013-02-21 21:36 yorik Note Added: 0002937
2013-02-21 21:36 yorik Status assigned => feedback
2013-03-23 15:13 yorik Note Added: 0002999
2013-03-23 15:13 yorik Status feedback => closed
2013-03-23 15:13 yorik Resolution open => fixed
2013-03-23 15:13 yorik Fixed in Version => 0.14