View Issue Details

IDProjectCategoryView StatusLast Update
0000937PartDesignBugpublic2015-01-06 22:38
ReporterghiaAssigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.12 
Target VersionFixed in Version0.13 
Summary0000937: Pocket has a negative cut out
DescriptionSee file of addendum
The Pocket has not only the 10 mm cut but also some cut in the opposite direction, which is uncontrolable by the GUI.
TagsNo tags attached.

Activities

2013-01-01 08:32

 

banjo1.FCStd (15,762 bytes)

ghia

2013-01-01 09:00

reporter   ~0002776

To cut away the circle part entirely, the user should have control to extend the pocket also in the negative direction.
Now a new sketch is needed on the flat face of the remaining segment (pocket.face10). A side effect from this second cut is that the two sketches become offsetted by this negative cut out from the pocket.
Further on, the resulting face (started as pocket.face8) becomes split in 3.
2 superfluous edges are created along the bottom border of the rectangle from the two sketches.

normandc

2013-01-06 17:01

manager   ~0002812

I opened your file, edited the Pocket feature, checked the "symmetric to plane" option then unchecked it, and the cut corrected itself.

Using the "symmetric to plane" option allows you to extend the pocket in the negative direction.

When reporting bugs, *always* mention your FreeCAD version and revision number. Also indicate your operating system and architecture (32 or 64-Bit).

You can get the FreeCAD version in Help --> About FreeCAD.

As for the split faces, this is caused by the Open Cascade CAD kernel, over which the FreeCAD team has no control. An experimental face cleaning utility has been added in the Part --> Refine shape menu. Be advised it is not parametric, if you make changes on your features the refined solid will not update, you'll need to delete it and recreate it, so wait at the very end of your model to use it. Once it is proven to work reliably, it will be included in all Part Design features and the end-user will not need to use it anymore.

OS: Ubuntu 12.04.1 LTS
Platform: 64-bit
Version: 0.13.1807 (Git)
Branch: master
Hash: 9eb41743156bc3522e778ce1e52c74669bc4c9fa
Python version: 2.7.3
Qt version: 4.8.1
Coin version: 3.1.3
SoQt version: 1.5.0
OCC version: 6.5.0

ghia

2013-01-06 18:46

reporter   ~0002816

This kind of editing is a feature of V0.13
In v0.12.5284 OS: Windows 7 Platform: 32-bit, this parameter is not present. You have only type : dimension (which is the only option) and Length to alter.

Seems in V0.13 the negative cut is no longer present when creating a pocket.
I assume this bug is resolved.

Altough the symmetric checkbox can solve many things, maybe a second input for length that handles the negative direction, would be a nice feature.

normandc

2013-01-12 20:27

manager   ~0002843

I agree, but it may be best to ask for this feature in a new bug report.

wmayer

2015-01-06 22:38

administrator   ~0005545

The issue was fixed in 0.13 and the symmetry option is also available.

Issue History

Date Modified Username Field Change
2013-01-01 08:32 ghia New Issue
2013-01-01 08:32 ghia File Added: banjo1.FCStd
2013-01-01 09:00 ghia Note Added: 0002776
2013-01-06 17:01 normandc Note Added: 0002812
2013-01-06 18:46 ghia Note Added: 0002816
2013-01-12 20:27 normandc Note Added: 0002843
2015-01-06 22:38 wmayer Note Added: 0005545
2015-01-06 22:38 wmayer Status new => closed
2015-01-06 22:38 wmayer Resolution open => fixed
2015-01-06 22:38 wmayer Fixed in Version => 0.13