View Issue Details

IDProjectCategoryView StatusLast Update
0000933FreeCADBugpublic2017-09-23 21:13
Reporterryback08Assigned Towmayer 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionreopened 
Product Version 
Target VersionFixed in Version0.17 
Summary0000933: Loft make no valid plane for sketcher
Descriptionabout "LOFT" tool on PART

I noticed something rather strange and random placement following :
# If you create two square aligned with the sketcher -> Utility "LOFT" to create your parallelogram -> all face are valid for the sketcher (so all is ok)
# If you don't align the two square, sketcher don't whant link on some face. But all face are plane !!!

if creating the same part with utility generation from 2 no-align square, the sketcher can run on all face (but it is much longer for the same part: select the vertices to create edges and faces. ....)

I link an exemple file
Steps To ReproduceEdit: per @wmayer in ~5591
I could easily confirm this.
* Open a sketch and draw a square where the origin is the center of the square
* Close the sketch and create a new one with an offset
* Draw again a square which is shifted by one grid cell. Closeit.
* Switch to Part and make a loft with option to create a solid

Clear the selection and then select the loft and enter this into the Python console:
for i in Gui.Selection.getSelectionEx()[0].Object.Shape.Faces: print i.Surface

For two faces it still reports a b-spline surface
TagsOCC Bug, OCC NotOnRoadmap, upstream

Activities

2012-12-29 10:35

 

Loft.FCStd (Attachment missing)

normandc

2013-01-06 17:13

manager   ~0002813

So the point is, Loft.Loft001.Face2 and Loft.Loft001.Face4 are planar, but Loft.Loft001.Face1 and Loft.Loft001.Face3 are BSpline surfaces, and they should be planar as well.

Discussion in forum (in French): http://forum.freecadweb.org/viewtopic.php?f=12&t=3376#p26275

normandc

2013-01-06 17:19

manager   ~0002814

2 things wrong with this bug

- Listed under [Draft], this is a Part tool
- Category is patch, but there is no patch included

jmaustpc

2013-01-12 13:16

manager   ~0002838

Norm, did these incorrectly render for you?

I just opened the file and the two boxes render fine.

I then followed these instructions starting from new and it still rendered correctly.

OS: Ubuntu 12.04.1 LTS
Platform: 64-bit
Version: 0.13.1822 (Git)
Branch: master
Hash: 3cdf8f4350ababe0b6d1dfc85cda8bdd80864c5c
Python version: 2.7.3
Qt version: 4.8.2
Coin version: 3.1.3
SoQt version: 1.5.0
OCC version: 6.5.0

ryback08

2013-01-12 18:43

reporter   ~0002840

Last edited: 2013-01-12 18:50

I tried to explain with my bad english

The render of two part is correctly (visual)
But, the surface generate about the second incliend boxe isn't plane, so, you didn't lock the face with stecker

On the first box make with loft tool, you can lock all face witch sketcher : that's great
On second inclined box make with loft tool too, many face generate by loft tool can't be lock with stecker. when you select face on incliened box and you click on "new sketch", you have warning message "you need plane face" or the face is theoretically plane.

Edit : I link picture for a better understanding

2013-01-12 18:48

 

Loft.png (Attachment missing)

normandc

2013-01-12 18:57

manager   ~0002841

ryback, you can change the language to English in Preferences/General/General before taking a screen capture, that way you don't need to translate what the message says. ;-)

jmaustpc

2013-01-14 10:27

manager   ~0002848

@ ryback08 Oh! right now I understand. :-)

@ Norm that's a good tip, I have to admit I didn't think of that! :-)

jmaustpc

2013-01-14 10:33

manager   ~0002849

Last edited: 2013-01-14 10:33

OK I have tested as well now and I see the same problem.

It is only the two faces on the ZX plane (the front and rear) that you can not attach a sketch to. All the other faces will work.

Something is not correct.

OS: Ubuntu 12.04.1 LTS
Platform: 64-bit
Version: 0.13.1822 (Git)
Branch: master
Hash: 3cdf8f4350ababe0b6d1dfc85cda8bdd80864c5c
Python version: 2.7.3
Qt version: 4.8.2
Coin version: 3.1.3
SoQt version: 1.5.0
OCC version: 6.5.0

2013-01-14 11:01

 

Loft_and_sweep_mytests2.FCStd (Attachment missing)

jmaustpc

2013-01-14 11:04

manager   ~0002850

The bug is not there in sweep. So as a temporary work around perhaps you could use sweep?

I just added a Line from Part WB and used it as the path for a sweep. See the file "Loft_and_sweep_mytests2.FCStd" which I just added above for an example if you like.

jmaustpc

2015-01-07 16:58

manager   ~0005566

I can no longer reproduce this old bug in current software
OS: Ubuntu 14.04.1 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.15.4435 (Git)
Branch: master
Hash: f24e216db4fb923b2571ad9d856f934e81bec797
Python version: 2.7.6
Qt version: 4.8.6
Coin version: 4.0.0a
OCC version: 6.7.1.oce-0.17-dev

jmaustpc

2015-01-07 16:59

manager   ~0005567

Current software no longer reproduces this bug.

wmayer

2015-01-08 11:12

administrator   ~0005591

Last edited: 2017-09-06 11:55

View 2 revisions

I could easily confirm this.
* Open a sketch and draw a square where the origin is the center of the square
* Close the sketch and create a new one with an offset
* Draw again a square which is shifted by one grid cell. Closeit.
* Switch to Part and make a loft with option to create a solid

Clear the selection and then select the loft and enter this into the Python console:
[code=python]for i in Gui.Selection.getSelectionEx()[0].Object.Shape.Faces: print i.Surface
[/code]
For two faces it still reports a b-spline surface

jmaustpc

2015-01-08 14:41

manager   ~0005599

I tested this with the file posted to this topic above. I tested by trying the attached a sketch to all faces and it did, so I thought the problem was gone. But doing as you say does cause the original bug still.

By the way, in case its relevant, If you select Ruled surface and solid you still get these Bspline surfaces.

bejant

2015-07-18 18:19

reporter   ~0006247

From what I read in the forum (and I can't locate that topic now), that the faces generated by Loft are not planar is an OpenCascade issue. In other words, that's just how OCC Loft works now and so until it changes in OCC it can't be changed in FreeCAD.

Kunda1

2017-01-12 12:18

manager   ~0007665

I updated the ticket description to indicate @wmayer steps-to-reproduce in ~5591
per @bejant in ~6427 should we tag this 'upstream' if so, is there an upstream ticket we can link to?

nemesis

2017-02-04 13:46

reporter   ~0008211

confirmed with OCC7
OS: Mac OS X
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.9944 (Git)
Build type: Release
Branch: (detached from 9b58d8b)
Hash: 9b58d8bd6fe19b0b921ffa0b5712186a0b3be09d
Python version: 2.7.13
Qt version: 4.8.7
Coin version: 3.1.3
OCC version: 7.0.0

Kunda1

2017-09-06 11:56

manager   ~0010072

@wmayer can you still reproduce ~5591 on OCC 7.2 ?

wmayer

2017-09-23 21:13

administrator   ~0010164

With https://github.com/FreeCAD/FreeCAD/commit/2611f072b786b77829e070d0eabc518a6ffea58b it is now supported to attach a sketch to a planar B-spline surface.

Issue History

Date Modified Username Field Change
2012-12-29 10:35 ryback08 New Issue
2012-12-29 10:35 ryback08 File Added: Loft.FCStd
2013-01-06 17:13 normandc Note Added: 0002813
2013-01-06 17:19 normandc Note Added: 0002814
2013-01-06 17:20 normandc Project Draft => FreeCAD
2013-01-12 11:28 Jriegel Category Patch => Bug
2013-01-12 11:28 Jriegel Product Version 0.14 =>
2013-01-12 13:16 jmaustpc Note Added: 0002838
2013-01-12 18:43 ryback08 Note Added: 0002840
2013-01-12 18:48 ryback08 File Added: Loft.png
2013-01-12 18:50 ryback08 Note Edited: 0002840
2013-01-12 18:57 normandc Note Added: 0002841
2013-01-14 10:27 jmaustpc Note Added: 0002848
2013-01-14 10:33 jmaustpc Note Added: 0002849
2013-01-14 10:33 jmaustpc Note Edited: 0002849
2013-01-14 11:01 jmaustpc File Added: Loft_and_sweep_mytests2.FCStd
2013-01-14 11:04 jmaustpc Note Added: 0002850
2015-01-07 16:58 jmaustpc Note Added: 0005566
2015-01-07 16:59 jmaustpc Note Added: 0005567
2015-01-07 16:59 jmaustpc Status new => closed
2015-01-07 16:59 jmaustpc Assigned To => jmaustpc
2015-01-07 16:59 jmaustpc Resolution open => no change required
2015-01-08 11:12 wmayer Note Added: 0005591
2015-01-08 11:12 wmayer Status closed => confirmed
2015-01-08 11:12 wmayer Resolution no change required => reopened
2015-01-08 14:41 jmaustpc Note Added: 0005599
2015-01-08 14:41 jmaustpc Assigned To jmaustpc =>
2015-07-18 18:19 bejant Note Added: 0006247
2017-01-12 12:15 Kunda1 Steps to Reproduce Updated View Revisions
2017-01-12 12:18 Kunda1 Note Added: 0007665
2017-01-30 15:53 Kunda1 Tag Attached: OCC Bug
2017-01-30 15:53 Kunda1 Tag Attached: upstream
2017-02-04 13:46 nemesis Note Added: 0008211
2017-09-06 11:55 Kunda1 Note Edited: 0005591 View Revisions
2017-09-06 11:56 Kunda1 Note Added: 0010072
2017-09-06 11:57 Kunda1 Tag Attached: OCC NotOnRoadmap
2017-09-23 21:13 wmayer Assigned To => wmayer
2017-09-23 21:13 wmayer Status confirmed => closed
2017-09-23 21:13 wmayer Fixed in Version => 0.17
2017-09-23 21:13 wmayer Note Added: 0010164