View Issue Details

IDProjectCategoryView StatusLast Update
0000919DraftBugpublic2012-12-20 22:30
Reporterts468Assigned Toyorik 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Product Version0.14 
Target VersionFixed in Version0.13 
Summary0000919: Crash on upgrade from wire to face
DescriptionUpgrading the lines from the attached file to a wire works fine, the subsequent upgrade to a face unfortunately leads to a core dump.
Additional InformationOS: Debian GNU/Linux testing (wheezy)
Platform: 64-bit
Version: 0.13.1779 (Git)
Branch: master
Hash: 480f28032279505f2399fe08ee41a32228026c0f
Python version: 2.7.3rc2
Qt version: 4.8.2
Coin version: 3.1.3
SoQt version: 1.5.0
OCC version: 6.5.2
TagsNo tags attached.

Activities

2012-12-19 22:07

 

test.dxf (36,773 bytes)

yorik

2012-12-20 00:24

administrator   ~0002674

Ok, confirmed. I'll look into it. Thanks for reporting!

wmayer

2012-12-20 13:21

administrator   ~0002678

git show 7408cc7 fixes the crash which I had in debug mode. In release mode everything works fine.

The problem is that the creation of the face from the wire failed and thus a call of normalAt() leads to the crash.

yorik

2012-12-20 14:42

administrator   ~0002679

Thanks Werner! I also corrected a bug in Draft that prevented the face to be created. git show 2d35c34

I'll close this bug report, don't hesitate to reopen if needed.

Issue History

Date Modified Username Field Change
2012-12-19 22:07 ts468 New Issue
2012-12-19 22:07 ts468 File Added: test.dxf
2012-12-20 00:24 yorik Status new => assigned
2012-12-20 00:24 yorik Assigned To => yorik
2012-12-20 00:24 yorik Note Added: 0002674
2012-12-20 13:21 wmayer Note Added: 0002678
2012-12-20 14:42 yorik Note Added: 0002679
2012-12-20 22:29 yorik Status assigned => closed
2012-12-20 22:30 yorik Resolution open => fixed
2012-12-20 22:30 yorik Fixed in Version => 0.13