View Issue Details

IDProjectCategoryView StatusLast Update
0000911FreeCADBugpublic2012-12-27 10:30
ReporterscopaevAssigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version0.13 
Summary0000911: V0.13- Faces of Solid models cannot be selected when ALT-TAB is used to switch between applications
DescriptionThis has been bugging me since 0.12, and I finally found how to make it repeatable (at least for me)!

If you have a model open, as you hover over different sections the faces all light up as they should.
THEN you ALT-TAB to another application such as firefox.
When you try and get back to FC (through any method) the following happens:
1. The faces are no longer selectable.
2. If you are creating a sketch you can no longer click on the main screen...therefore you cannot draw on the screen, measure from the screen, apply constraints on the screen, etc.

I have tested this on ubuntu 10.04 and 12.04 (both 64-bit) and it happens on both.
To make FC work again, I have been restarting it.

Now, that I know what it is I can try and avoid using Alt-Tab for now.

I don't know if this happens on a mac or windows machine. Have any other ubuntu-ers seen this, or is there something special about my setups?

Thanks for listening!

For those of you who have Ubuntu 12.04 you will notice by default ALt-tab is disabled. To enable it:
sudo apt-get install compizconfig-settings-manager
Then (assuming using gnome classic): Applications -> System Tools -> Preferences -> CompizConfig Settings Manager->Window Management: activate "Static Application Switcher"
Additional InformationOS: Ubuntu 10.04.4 LTS
Platform: 64-bit
Version: 0.13.1737 (Git)
Branch: master
Hash: 64e1c3635df8d91fb569e0ac74a8402725e8b50a
Python version: 2.6.5
Qt version: 4.6.2
Coin version: 3.1.2
SoQt version: 1.4.2a
OCC version: 6.3.0
TagsNo tags attached.

Activities

yorik

2012-12-08 22:29

administrator   ~0002630

This bug doesn't happen for me on debian... Try disabling your desktop effects?

scopaev

2012-12-09 15:27

reporter   ~0002631

Thanks for checking yorik. Out of curiosity is your system 32/64 bit?

Just checked, my desktop effects are off for both systems.
I also tried logging in with Gnome, Gnome Classic, Gnome Classic (no effects), Unity, Unity 2D. All have the same weird issue.

Just installed FC on an old 32bit laptop with ubuntu 10.04 on it and FC works fine there.

Tomorrow, I will try and install a fresh 64 bit ubuntu 12.04 on a newer system and see what happens. I will try and narrow down exactly what combination of OS, and software is causing this effect for me.

yorik

2012-12-09 21:11

administrator   ~0002632

My system is 64bit too.
This looks like some issue with OpenGL windows... If the same problem happens with blender, that would confirm it. I would guess the culprit is the 3D driver...

2012-12-17 16:55

 

GnomeAltTab1.ogv (Attachment missing)

scopaev

2012-12-17 16:57

reporter   ~0002650

Update:

This bug can be closed out. It seems to be an inconsistancy in Ubuntu.

Temporary fix: I have found that if I ALT-ALT (Press and release ALT twice) on the FreeCAD screen the focus comes back
(which is great since I don't have to close out my workarea anymore).

I have also added a video so other folks that may experience this in future can confirm its the same thing.
In video:
  First: normal mouse highlighing works on main part as well as direction cubes
  Second: I ALT-TAB: Main part highlighting freezes, but direction cubes work ok.
  Third: I ALT-ALT: everything goes back to normal without closing out work screen.

This appears to be an ubuntu issue of sorts (drivers or something, I cant narrow down).
I have installed a fresh version of ubuntu 12.04.1 with gnome classic and just freecad twice on same machine.
The first time the problem was there, the second time it was gone. It's inconsistant (or my installation method was).
Yet I still have 2 updated Pc's with the issue.

There are other folks complaining of ALT-TAB window Focus loss on the ubuntu bug tracker.
Once I can find a consistant way of making it happen I will add to a bug report with Ubuntu.
https://bugs.launchpad.net/ubuntu/+source/unity/+bug/1035628

Unless there is something that FC can do about reclaming focus, I would say close this thing out.

yorik

2012-12-17 18:07

administrator   ~0002651

Okay indeed it seems this is not connected to FreeCAD... As for claiming focus, I don't think it is something the application itself can do (or should do). I'll close this then.

scopaev

2012-12-26 16:36

reporter   ~0002762

Some folks were able to narrow down a way to make this occur consistantly.

It seems to be linked to using "Blender" navigation instead of "CAD" navigation.

http://forum.freecadweb.org/viewtopic.php?f=3&t=3369&start=10

yorik, can you verify if you can make this happen?
Thanks

wmayer

2012-12-27 10:30

administrator   ~0002763

git show 97b6128

Issue History

Date Modified Username Field Change
2012-12-08 15:56 scopaev New Issue
2012-12-08 22:29 yorik Note Added: 0002630
2012-12-09 15:27 scopaev Note Added: 0002631
2012-12-09 21:11 yorik Note Added: 0002632
2012-12-17 16:55 scopaev File Added: GnomeAltTab1.ogv
2012-12-17 16:57 scopaev Note Added: 0002650
2012-12-17 18:07 yorik Note Added: 0002651
2012-12-17 18:07 yorik Status new => closed
2012-12-17 18:07 yorik Resolution open => unable to reproduce
2012-12-17 18:07 yorik Fixed in Version => 0.13
2012-12-26 16:36 scopaev Note Added: 0002762
2012-12-26 16:36 scopaev Status closed => feedback
2012-12-26 16:36 scopaev Resolution unable to reproduce => reopened
2012-12-27 10:30 wmayer Note Added: 0002763
2012-12-27 10:30 wmayer Status feedback => closed
2012-12-27 10:30 wmayer Resolution reopened => fixed