View Issue Details

IDProjectCategoryView StatusLast Update
0000906PartDesignBugpublic2012-12-07 12:05
ReporterdanielpoplawskiAssigned To 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version0.13 
Summary0000906: Segmentation Fault when try to use linear pattern on Part
DescriptionFreeCAD crash with Segmentation Fail when try to create linear pattern on Part. Part created on different version FreeCAD (0.12 from Ubuntu repo).
Additional InformationFreeCAD:
Version: 0.13
Revision number: 1737 (Git)
Operating system: Ubuntu 12.04.1 LTS (it's Kubuntu)
Platform: 32-bit
Branch: master
Own compilation with dependencies from ubuntu repos.
=======================================================
uname -r
3.2.0-34-generic-pae

=======================================================
I have core dump but it's 177 MB.
Backtrace form gdb:
Reading symbols from /usr/bin/FreeCAD...(no debugging symbols found)...done.
[New LWP 31524]
[New LWP 31527]
[New LWP 31528]
[New LWP 31531]
[New LWP 31534]
[New LWP 31533]
[New LWP 31530]
[New LWP 31532]
[New LWP 31529]

warning: Can't read pathname for load map: B??d wej?cia/wyj?cia.
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
Core was generated by `FreeCAD'.
Program terminated with signal 11, Segmentation fault.
#0 0xaa04ea38 in TopoDS_ListIteratorOfListOfShape::Initialize(TopoDS_ListOfShape const&) () from /usr/lib/libTKBRep-6.5.0.so
(gdb) bt
#0 0xaa04ea38 in TopoDS_ListIteratorOfListOfShape::Initialize(TopoDS_ListOfShape const&) () from /usr/lib/libTKBRep-6.5.0.so
#1 0xaa096fee in TopoDS_Iterator::Initialize(TopoDS_Shape const&, unsigned int, unsigned int) () from /usr/lib/libTKBRep-6.5.0.so
#2 0xaa070628 in BRepTools_Modifier::Put(TopoDS_Shape const&) () from /usr/lib/libTKBRep-6.5.0.so
#3 0xaa0707c6 in BRepTools_Modifier::Init(TopoDS_Shape const&) () from /usr/lib/libTKBRep-6.5.0.so
#4 0xa9eeabfb in BRepBuilderAPI_ModifyShape::DoModif(TopoDS_Shape const&) () from /usr/lib/libTKTopAlgo-6.5.0.so
#5 0xa9edb3ab in BRepBuilderAPI_Copy::BRepBuilderAPI_Copy(TopoDS_Shape const&, unsigned int) () from /usr/lib/libTKTopAlgo-6.5.0.so
#6 0xa1f1a8bd in PartDesign::Transformed::execute() () from /opt/freecad/Mod/PartDesign/PartDesign.so
#7 0xb6c628dd in App::DocumentObject::recompute() () from /opt/freecad/lib/libFreeCADApp.so
#8 0xab5ea59f in Part::Feature::recompute() () from /opt/freecad/Mod/Part/Part.so
#9 0xb6c251bf in App::Document::_recomputeFeature(App::DocumentObject*) () from /opt/freecad/lib/libFreeCADApp.so
#10 0xb6c24edf in App::Document::recompute() () from /opt/freecad/lib/libFreeCADApp.so
#11 0xb6c7dc6e in App::DocumentPy::recompute(_object*) () from /opt/freecad/lib/libFreeCADApp.so
#12 0xb6c79736 in App::DocumentPy::staticCallback_recompute(_object*, _object*) () from /opt/freecad/lib/libFreeCADApp.so
#13 0xb66f78cf in PyCFunction_Call () from /usr/lib/libpython2.7.so.1.0
#14 0xb66568bf in PyEval_EvalFrameEx () from /usr/lib/libpython2.7.so.1.0
#15 0xb660c4d2 in PyEval_EvalCodeEx () from /usr/lib/libpython2.7.so.1.0
#16 0xb660c813 in PyEval_EvalCode () from /usr/lib/libpython2.7.so.1.0
#17 0xb660c8b3 in PyRun_StringFlags () from /usr/lib/libpython2.7.so.1.0
#18 0xb699f4a1 in Base::InterpreterSingleton::runString(char const*) () from /opt/freecad/lib/libFreeCADBase.so
#19 0xb7118c77 in Gui::Command::doCommand(Gui::Command::DoCmd_Type, char const*, ...) () from /opt/freecad/lib/libFreeCADGui.so
#20 0xb7119022 in Gui::Command::updateActive() () from /opt/freecad/lib/libFreeCADGui.so
#21 0xa1d1b818 in CmdPartDesignLinearPattern::activated(int) () from /opt/freecad/Mod/PartDesign/PartDesignGui.so
#22 0xb7118560 in Gui::Command::invoke(int) () from /opt/freecad/lib/libFreeCADGui.so
#23 0xb710fc80 in Gui::Action::onActivated() () from /opt/freecad/lib/libFreeCADGui.so
#24 0xb71148f7 in Gui::Action::qt_static_metacall(QObject*, QMetaObject::Call, int, void**) () from /opt/freecad/lib/libFreeCADGui.so
#25 0xb59836b1 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#26 0xb5c409bd in QAction::triggered(bool) () from /usr/lib/i386-linux-gnu/libQtGui.so.4
#27 0xb5c40c5b in QAction::activate(QAction::ActionEvent) () from /usr/lib/i386-linux-gnu/libQtGui.so.4
#28 0xb614d410 in QToolButton::nextCheckState() () from /usr/lib/i386-linux-gnu/libQtGui.so.4
#29 0xb6074c57 in ?? () from /usr/lib/i386-linux-gnu/libQtGui.so.4
#30 0xb6074f56 in QAbstractButton::mouseReleaseEvent(QMouseEvent*) () from /usr/lib/i386-linux-gnu/libQtGui.so.4
#31 0xb614d4ad in QToolButton::mouseReleaseEvent(QMouseEvent*) () from /usr/lib/i386-linux-gnu/libQtGui.so.4
#32 0xb5ca21ac in QWidget::event(QEvent*) () from /usr/lib/i386-linux-gnu/libQtGui.so.4
#33 0xb60741f9 in QAbstractButton::event(QEvent*) () from /usr/lib/i386-linux-gnu/libQtGui.so.4
#34 0xb614ebdc in QToolButton::event(QEvent*) () from /usr/lib/i386-linux-gnu/libQtGui.so.4
#35 0xb5c47ed4 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/i386-linux-gnu/libQtGui.so.4
#36 0xb5c4e024 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/i386-linux-gnu/libQtGui.so.4
#37 0xb70b5604 in Gui::GUIApplication::notify(QObject*, QEvent*) () from /opt/freecad/lib/libFreeCADGui.so
#38 0xb596c97e in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#39 0xb5c48e95 in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool) () from /usr/lib/i386-linux-gnu/libQtGui.so.4
#40 0xb5cd5074 in ?? () from /usr/lib/i386-linux-gnu/libQtGui.so.4
#41 0xb5cd3c0d in QApplication::x11ProcessEvent(_XEvent*) () from /usr/lib/i386-linux-gnu/libQtGui.so.4
#42 0xb5d00eac in ?? () from /usr/lib/i386-linux-gnu/libQtGui.so.4
#43 0xb404bd86 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#44 0xb404c125 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#45 0xb404c201 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#46 0xb599f887 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#47 0xb5d00aaa in ?? () from /usr/lib/i386-linux-gnu/libQtGui.so.4
#48 0xb596b50d in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#49 0xb596b7a9 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#50 0xb5970eba in QCoreApplication::exec() () from /usr/lib/i386-linux-gnu/libQtCore.so.4
#51 0xb5c45a74 in QApplication::exec() () from /usr/lib/i386-linux-gnu/libQtGui.so.4
#52 0xb70b1bd8 in Gui::Application::runApplication() () from /opt/freecad/lib/libFreeCADGui.so
#53 0x0804f1b9 in main ()

===================================================

Attached file is my simple project that crash. I tried Linear pattern on "Revlotion" Part.
TagsNo tags attached.

Activities

2012-12-07 09:00

 

prototype-test.FCStd (13,409 bytes)

wmayer

2012-12-07 11:48

administrator   ~0002623

Your Revolution object is broken because it hasn't defined an axis. But there are also some checks required when doing the pattern feature to avoid the crash.

wmayer

2012-12-07 12:04

administrator   ~0002624

git show 3c3abd4

Issue History

Date Modified Username Field Change
2012-12-07 09:00 danielpoplawski New Issue
2012-12-07 09:00 danielpoplawski File Added: prototype-test.FCStd
2012-12-07 11:48 wmayer Note Added: 0002623
2012-12-07 12:04 wmayer Note Added: 0002624
2012-12-07 12:04 wmayer Status new => closed
2012-12-07 12:05 wmayer Resolution open => fixed
2012-12-07 12:05 wmayer Fixed in Version => 0.13