View Issue Details

IDProjectCategoryView StatusLast Update
0000891DraftBugpublic2012-12-20 22:23
Reportermore10Assigned Toyorik 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version0.12 
Target VersionFixed in Version0.13 
Summary0000891: Snap to intersection doesn't work in draft module
DescriptionIn draft module the working plane is set to a surface not aligned to any axis.

Snapping to intersection doesn't work. When only intersection is enabled, intersection is indicated only for where endpoints meet.
Additional Informationrevision 1694 on a 32 bit ubuntu running in vmware workstation.
TagsNo tags attached.

Relationships

has duplicate 0000892 closedyorik Snap to grid cannot be turned off 
child of 0000893 closedyorik Fail to upgrade wire to face in drafting module 

Activities

yorik

2012-11-28 23:51

administrator   ~0002594

To have intersection to work, you need to pass the mouse first on the 2 objects you want to find the intersection of... Sorry, that is not well documented yet.

more10

2012-11-29 00:36

reporter   ~0002598

I have tried that. Use the drawing I uploaded, using the same drafting plane as the other bugs I reported.

yorik

2012-11-29 20:13

administrator   ~0002600

Hm the problem is that the curved edges of your solid object are bsplines (this happens often with the opencascade engine), and until now I couldn't find a way to find an intersection on a bspline... I'm afraid I won't be able to solve this one now. But I'll definitely add this to the documentation...

yorik

2012-11-29 20:15

administrator   ~0002601

that said, there is really a problem even with straight lines, related to bug #893

yorik

2012-12-20 22:23

administrator   ~0002732

This is fixed in 496a216

Issue History

Date Modified Username Field Change
2012-11-28 21:50 more10 New Issue
2012-11-28 23:51 yorik Note Added: 0002594
2012-11-28 23:55 yorik Status new => assigned
2012-11-28 23:55 yorik Assigned To => yorik
2012-11-29 00:36 more10 Note Added: 0002598
2012-11-29 20:13 yorik Note Added: 0002600
2012-11-29 20:15 yorik Note Added: 0002601
2012-11-29 20:16 yorik Relationship added child of 0000893
2012-11-29 20:18 yorik Relationship added has duplicate 0000892
2012-12-05 13:50 yorik Project FreeCAD => Draft
2012-12-20 22:23 yorik Note Added: 0002732
2012-12-20 22:23 yorik Status assigned => closed
2012-12-20 22:23 yorik Resolution open => fixed
2012-12-20 22:23 yorik Fixed in Version => 0.13