View Issue Details

IDProjectCategoryView StatusLast Update
0000866DraftBugpublic2012-11-02 20:03
Reportermzahor1Assigned Toyorik 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version0.13 
Summary0000866: Converting from draft to sketch - object is lost without error
DescriptionHi,

I'm using 0.13 version for MAC OS X [ Mountail Lion ]
I've imported PATHs from SVG file. Converting from DRAFT to SKETCH doesn't work - selected PATH just
disappears without error message in Report View. Sketch object in "Labels and Attributes" is added but is empty.
TagsNo tags attached.

Activities

2012-11-02 12:29

 

Untitled 3.svg (1,189,475 bytes)

wmayer

2012-11-02 18:35

administrator   ~0002483

Btw, the SVG import is broken. See http://forum.freecadweb.org/viewtopic.php?f=3&t=3163

The sketch is empty because the draft contains only b-spline curves which cannot be converted into sketch equivalents.

@Yorik, would it be possible to change the behaviour of the command that it does NOT delete the draft objects?

yorik

2012-11-02 20:03

administrator   ~0002485

Done in e29de5d

Indeed the problem is that all the edges of the imported object are bsplines, which are not supported yet by the sketcher. I did a small change so the user is now notified of the problem, and as Werner suggests, the original object is never deleted anymore (this is indeed safer until that tool works fully as expected).

I also fixed the problem in SVG import as stated in the forum post.

Issue History

Date Modified Username Field Change
2012-11-02 12:29 mzahor1 New Issue
2012-11-02 12:29 mzahor1 File Added: Untitled 3.svg
2012-11-02 17:54 yorik Status new => assigned
2012-11-02 17:54 yorik Assigned To => yorik
2012-11-02 18:35 wmayer Note Added: 0002483
2012-11-02 20:03 yorik Note Added: 0002485
2012-11-02 20:03 yorik Status assigned => closed
2012-11-02 20:03 yorik Resolution open => fixed
2012-11-02 20:03 yorik Fixed in Version => 0.13