View Issue Details

IDProjectCategoryView StatusLast Update
0000864FreeCADBugpublic2013-06-29 15:02
ReporterpervicesAssigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version0.14 
Summary0000864: Skin remains when cutting rectangle
DescriptionUsing git version:
FreeCAD 0.13, Libs: 0.13R1535 (Git: 8de40bc3a)

When cutting a rectangular shape out, part of the object is left behind (i.e., not a clean cut). Confirmed on another computer.

Result in attached file. Tools used when producing result:
1. Use DWire to make shape
2. Place circles in required locations
3. Place rectangle in required location
4. Extrude all elements
5. Select main shape, select cut out shape, use the "Make a cut" button to remove selected cut out shape
6. Works for all elements except for the rectangle







TagsNo tags attached.

Activities

2012-10-30 21:56

 

NOCTAR-bracket.FCStd (Attachment missing)

Jriegel

2012-10-31 05:20

administrator   ~0002478

Can confirm the problem, but put it on low prio.
This kind of modeling (CSG) is not preferred and known to lead to problems
due to easely count up small errors.
Please use PartDesign Sketcher and Pad/Pocket for such a modeling.

wmayer

2013-06-29 15:02

administrator   ~0003294

Using OCC 6.5 there issue is still there but when switching to OCC 6.6 it disappears. So, it was actually an OCC bug

Issue History

Date Modified Username Field Change
2012-10-30 21:56 pervices New Issue
2012-10-30 21:56 pervices File Added: NOCTAR-bracket.FCStd
2012-10-31 05:20 Jriegel Note Added: 0002478
2012-10-31 05:20 Jriegel Reproducibility have not tried => always
2012-10-31 05:20 Jriegel Status new => acknowledged
2013-06-29 15:02 wmayer Note Added: 0003294
2013-06-29 15:02 wmayer Status acknowledged => closed
2013-06-29 15:02 wmayer Resolution open => fixed
2013-06-29 15:02 wmayer Fixed in Version => 0.14