View Issue Details

IDProjectCategoryView StatusLast Update
0000862DraftBugpublic2013-06-15 18:04
ReporterwmayerAssigned Toyorik 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target Version0.14Fixed in Version0.14 
Summary0000862: Draft toolbar doesn't disappear when switching workbenches
DescriptionSteps to reproduce:
* From e.g. Part workbench go to Draft
* Go to Part
* Go to Draft
* Go to Part

Now, there is a tool bar (Draft Snap) that doesn't disappear but the others do. And when checking the available tool bars in the View menu the Draft Snap isn't listed there.
TagsNo tags attached.

Activities

yorik

2012-10-30 10:44

administrator   ~0002474

Actually that was at first the intended behaviour (that you could still use the draft snaps in other modules). The other problem (when switching workbenches, the name of the draft toolbar doesn't appear in the list) I couldn't solve yet...

But actually that draft toolbar is at the moment a quick hack (all made in pyqt), and needs to be redone properly, using FreeCAD commands. This will solve both problems at once. I'll schedule it for after 0.13...

wmayer

2013-06-13 18:35

administrator   ~0003201

git show 5a04ade should fix it. The snap toolbar now also appears in the Menu. And there is a translation fix.

yorik

2013-06-15 18:04

administrator   ~0003218

Aah I see, the trick was to specify its parent! Excellent, thanks for the fix Werner

Issue History

Date Modified Username Field Change
2012-10-30 09:40 wmayer New Issue
2012-10-30 09:40 wmayer Status new => assigned
2012-10-30 09:40 wmayer Assigned To => yorik
2012-10-30 10:44 yorik Note Added: 0002474
2012-10-30 10:45 yorik Target Version => 0.14
2012-10-30 10:46 yorik Project FreeCAD => Draft
2013-06-13 18:35 wmayer Note Added: 0003201
2013-06-13 18:35 wmayer Status assigned => resolved
2013-06-13 18:35 wmayer Fixed in Version => 0.14
2013-06-13 18:35 wmayer Resolution open => fixed
2013-06-15 17:23 wmayer Status resolved => closed
2013-06-15 18:04 yorik Note Added: 0003218