View Issue Details

IDProjectCategoryView StatusLast Update
0000859FreeCADBugpublic2012-12-05 13:46
ReporterpervicesAssigned Toyorik 
PrioritynormalSeveritycrashReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version0.13 
Summary0000859: Deleting wires/dimensions causes illegal storage crash
DescriptionUsing git version:
FreeCAD 0.13, Libs: 0.13R1535 (Git: 8de40bc3a)

When attempting to delete a line or dimension from the Project: Labels & Attributes (regardless of mode), the program crashes and reports "illegal storage access..."

To reproduce:
1. Open freecad-git

2. Load, through the file -> open file the attached file (NOCTAR-bracket.FCStd)

3. Select "Dimension" from the Labels & Attributes list (under project)

4. When highlighted, press "delete"

Expected result:

Dimension line is removed from the draft/drawing

Actual result:

Program crash with "Illegal storage access..." reported
Additional InformationThis issue was also reproduced by my co-founder and when toggling the edit mode, the following errors occurred:


ViewProviderPythonFeature::setEdit (Dimension): No such command 'Draft_Edit'
ViewProviderPythonFeature::unsetEdit (Dimension): 'module' object has no
attribute 'activeDraftCommand'
ViewProviderPythonFeature::setEdit (DWire): No such command 'Draft_Edit'
Exception (Mon Oct 29 19:12:27 2012): Failed to set object 'DWire' in edit mode
Stack Trace: Traceback (most recent call last):
  File "<string>", line 1, in <module>

ViewProviderPythonFeature::setEdit (DWire): No such command 'Draft_Edit'
Exception (Mon Oct 29 19:12:31 2012): Failed to set object 'DWire' in edit mode
Stack Trace: Traceback (most recent call last):
  File "<string>", line 1, in <module>

ViewProviderPythonFeature::setEdit (Line006): No such command 'Draft_Edit'
Exception (Mon Oct 29 19:12:40 2012): Failed to set object 'Line006' in edit mode
Stack Trace: Traceback (most recent call last):
  File "<string>", line 1, in <module>

Illegal storage access...

----

A very cursory search of the forum finds that this bug MAY be related to #722
TagsNo tags attached.

Activities

2012-10-29 22:30

 

NOCTAR-bracket.FCStd (Attachment missing)

yorik

2012-10-30 01:20

administrator   ~0002472

Hm we had that bug some time ago already... I'll have a look

pervices

2012-10-30 20:04

reporter   ~0002477

Last edited: 2012-10-30 20:04

Thank you very much for looking into this.

We have been having a number of problems with stability. We have tried logging the errors but it has not really helped, we were hoping for more verbose logs.

For background info, we are running arch linux 3.6.2 kernel on a 64-bit system

pervices

2012-11-06 18:34

reporter   ~0002494

Some additional information:

When opening the file directly (without having freecad-git open) you are able to delete objects without crashing. The problem still exists when opening the file from the file-->open graphical interface.

pervices

2012-11-07 14:15

reporter   ~0002502

Also, it is possible to delete the attributes (e.g., dimension lines, measurements, etc.) by right clicking on the attribute in the project tree and selecting delete. Crash occurs when using delete key from key board.

yorik

2012-11-09 12:33

administrator   ~0002504

Hi,

Thanks for all your feedback on that matter... Unfortunately I can't reproduce the problem, neither in your attached file following the steps above, nor in any other combination. In fact I can't make it crash by deleting dimensions anymore...

I remember in the past this problem was very hard to debug because it happened sometimes yes sometimes no and I never could fully determine a set of conditions that made it always happen.

I'm wondering if it could be somehow related to the opengl view... What is your 3D chip and what driver do you use?

wmayer

2012-11-10 10:01

administrator   ~0002505

Apparently you built your FreeCAD version yourself. Then could you run FreeCAD in the debugger and post the stacktrace here, please?

pervices

2012-11-12 15:40

reporter   ~0002508

Sorry, just looking at this now. I was able to reproduce the problem in debug and attached the output.

Unfortunately I do not have symbols enabled, but the file may still help you.

2012-11-12 15:41

 

debug-report (Attachment missing)

wmayer

2012-12-04 11:40

administrator   ~0002609

Hm, according to stack trace it looks similar to #665.

yorik

2012-12-04 12:21

administrator   ~0002610

It could be... Maybe I'm foolded because the OP says it happens with Draft dimensions, which looks like a bug we had before. But indeed the trace contain no reference to coin, which is not like the other bug... In case you are right Werner, the bug should be fixed with the latest revision, right? pervices, can you check?

pervices

2012-12-05 13:44

reporter   ~0002612

This bug is fixed in the latest revision but other more major problems occurred for me. I have reported these as a new ticket (899)

Issue History

Date Modified Username Field Change
2012-10-29 22:30 pervices New Issue
2012-10-29 22:30 pervices File Added: NOCTAR-bracket.FCStd
2012-10-30 01:20 yorik Note Added: 0002472
2012-10-30 01:20 yorik Status new => assigned
2012-10-30 01:20 yorik Assigned To => yorik
2012-10-30 20:04 pervices Note Added: 0002477
2012-10-30 20:04 pervices Note Edited: 0002477
2012-11-06 18:34 pervices Note Added: 0002494
2012-11-07 14:15 pervices Note Added: 0002502
2012-11-09 12:33 yorik Note Added: 0002504
2012-11-10 10:01 wmayer Note Added: 0002505
2012-11-12 15:40 pervices Note Added: 0002508
2012-11-12 15:41 pervices File Added: debug-report
2012-12-04 11:40 wmayer Note Added: 0002609
2012-12-04 12:21 yorik Note Added: 0002610
2012-12-05 13:44 pervices Note Added: 0002612
2012-12-05 13:46 yorik Status assigned => closed
2012-12-05 13:46 yorik Resolution open => fixed
2012-12-05 13:46 yorik Fixed in Version => 0.13