View Issue Details

IDProjectCategoryView StatusLast Update
0000832FreeCADFeaturepublic2013-07-01 10:19
ReportervdhproductsAssigned To 
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version0.14 
Summary0000832: Original color STEP model lost in import
DescriptionDear Sir/Madam,

When I import a STEP file from 3DContentcentral(see uploaded file), the original colors of the STEP file are lost. There is only one color(green)left. In Altium designer the original color is intact.

How can I import/export the original color?

Kind regards,
Peter van Riessen
Additional InformationI am using freecad 0.13 1453(GIT)on Windows XP Professional SP3
TagsNo tags attached.

Activities

2012-09-13 10:07

 

1984772.stp (Attachment missing)

pperisin

2012-09-13 11:02

reporter   ~0002390

Hi,

you need to switch to Part Workbench, and choose Part - Import CAD.

I just tested in Altium, Cad Exchanger and FreeCAD (Part - import CAD command) - they all import it the same.

Regards
Petar

vdhproducts

2012-09-13 11:19

reporter   ~0002391

Hi Petar,

Thanks. I used the Complete Workbench at start-up, so I didn't see the CAD import.

A really good 3D CAD program! Keep up the good work!

Best regards,
Peter van Riessen

pperisin

2012-09-13 11:25

reporter   ~0002392

Last edited: 2012-09-13 11:26

No problem.

EDIT: since this is a common question, maybe it would be worth to consider moving STEP with colors import to regular "File >> Import" command.

wmayer

2012-09-14 12:17

administrator   ~0002394

We can have both, the simple and the advanced STEP import. With the simple approach we also include colors partially but here it might be better to import only the plain data and nothing else because it only confuses people if not all colors are loaded.

Then we can have the advanced STEP import (STEP 214) which imports colors and names. The file filter can be labelled "STEP 214".

pperisin

2012-09-14 12:54

reporter   ~0002395

Hi,

Ok, that is no problem. Not this might be little weird, but can we have "Regular" step, and "Simple" Step importer. So that default one is advanced, that imports most stuff, but if user wants, they can use simple one. Simple can be named AP203.

I'm saying this because IMO most want to use advanced one. I haven't used simple one in ages.

Regards,
Petar

pperisin

2012-09-14 18:33

reporter   ~0002396

Or maybe something else:

if you look at this Step file posted here in text editor - it has description : STEP AP214.

I do not know a lot about STEP, but maybe STEP file itself has info about what version it uses, described by standard.

In this case there could be three STEP importers: default, AP203 and AP214. Default one reads from file version, and uses appropriate importer, but if user wants to force AP203 or AP214, he could.

You decide. :-)

normandc

2012-09-19 21:33

manager   ~0002406

Last edited: 2012-09-19 21:34

I have a question: why have two different import utilities, one in Edit and the other in Part menu? This is confusing for the end user.

wmayer

2012-09-20 06:37

administrator   ~0002408

Because at that point the STEP 214 import was supposed to be experimental and thus was added to a not so obvious place.

pperisin

2012-09-20 13:11

reporter   ~0002411

Last edited: 2012-09-20 13:12

Now it seems pretty stable to me. How about using only big one?

EDIT: Maybe both can be added to part-import cad, just so if I have issues with one I can still test another one.

but the big one only can be in file-import

wmayer

2012-09-21 11:09

administrator   ~0002415

We can have STEP 214 the default one in File > Open/Import but I want to have the simple STEP import, too -- maybe only available in the Part menu.
I recently discovered a crash in the OCAF framework which happened on a 64-bit machine with the file above and thus we need a way to at least load the plain data.

Then, we should maybe split "CAD formats", i.e. we have 3 items in the file type list instead of one. So, we have: "STEP 214 (*.step *.stp)", "IGES (*.iges *.igs)" and "BREP (*.brep *.brp)" This solves the problem on the GNOME file dialog which hides all the file extensions.

pperisin

2012-09-23 11:57

reporter   ~0002423

Good idea about splitting CAD formats.

One more idea for STEP - CATIA (and maybe some others too) have only one STEP in import, but in it's preferences you can set weather you wish to use AP203 or AP214.

At first I did not like this, but now it does not sound so bad after all...

wmayer

2012-09-29 11:51

administrator   ~0002428

git show f403295

normandc

2012-12-15 19:43

manager   ~0002639

Last edited: 2012-12-15 19:44

I don't know why, but STEP colors don't work anymore in latest PPA version.

I export a FreeCAD part which has a defined color as STEP, import it back, the imported part is always grey. I tried Edit --> Import and Part --> CADĀ import, with the same result.

I imported the step file attached with this bug report, as well as the one in bug #0000439, same thing, all colors are lost.

OS: Ubuntu 12.04.1 LTS
Platform: 64-bit
Version: 0.13.1764 (Git)
Branch: master
Hash: 043dc60403603a4bdeb4dadd8f4c830776fc9f52
Python version: 2.7.3
Qt version: 4.8.1
Coin version: 3.1.3
SoQt version: 1.5.0
OCC version: 6.5.0

normandc

2012-12-15 19:48

manager   ~0002640

Same bug with compiled version from source.

OS: Ubuntu 12.04.1 LTS
Platform: 64-bit
Version: 0.13.1766 (Git)
Branch: master
Hash: d60fc3e0bb13f57fa5691876a29ac21884305c99
Python version: 2.7.3
Qt version: 4.8.1
Coin version: 3.1.3
SoQt version: 1.5.0
OCC version: 6.5.0

pperisin

2012-12-15 20:04

reporter   ~0002641

Last edited: 2012-12-15 20:04

file - import - step with colors

is command now

normandc

2012-12-15 20:24

manager   ~0002642

OK, I hadn't realized this setting, so this works as intended, but I still find it impractical for this reason:

At export the Step label seems set to the selected feature, not the original filename. For example my original filename is Y_Bearing.FCStd. I select the last feature which is Chamfer002 and export it as STEP colors. In a new document, I import it as STEP colors, the imported object is labeled Chamfer002 instead of Y_Bearing...

wmayer

2013-07-01 10:19

administrator   ~0003315

On File>Import/Export now always STEP with colors is used.

Issue History

Date Modified Username Field Change
2012-09-13 10:07 vdhproducts New Issue
2012-09-13 10:07 vdhproducts File Added: 1984772.stp
2012-09-13 11:02 pperisin Note Added: 0002390
2012-09-13 11:19 vdhproducts Note Added: 0002391
2012-09-13 11:25 pperisin Note Added: 0002392
2012-09-13 11:26 pperisin Note Edited: 0002392
2012-09-14 12:17 wmayer Note Added: 0002394
2012-09-14 12:54 pperisin Note Added: 0002395
2012-09-14 18:33 pperisin Note Added: 0002396
2012-09-19 21:33 normandc Note Added: 0002406
2012-09-19 21:34 normandc Note Edited: 0002406
2012-09-20 06:37 wmayer Note Added: 0002408
2012-09-20 13:11 pperisin Note Added: 0002411
2012-09-20 13:12 pperisin Note Edited: 0002411
2012-09-21 11:09 wmayer Note Added: 0002415
2012-09-23 11:57 pperisin Note Added: 0002423
2012-09-29 11:51 wmayer Note Added: 0002428
2012-09-29 11:51 wmayer Status new => closed
2012-09-29 11:51 wmayer Resolution open => fixed
2012-09-29 11:51 wmayer Fixed in Version => 0.13
2012-12-15 19:43 normandc Note Added: 0002639
2012-12-15 19:43 normandc Status closed => feedback
2012-12-15 19:43 normandc Resolution fixed => reopened
2012-12-15 19:44 normandc Note Edited: 0002639
2012-12-15 19:48 normandc Note Added: 0002640
2012-12-15 20:04 pperisin Note Added: 0002641
2012-12-15 20:04 pperisin Note Edited: 0002641
2012-12-15 20:24 normandc Note Added: 0002642
2013-07-01 10:19 wmayer Note Added: 0003315
2013-07-01 10:19 wmayer Status feedback => closed
2013-07-01 10:19 wmayer Resolution reopened => fixed
2013-07-01 10:19 wmayer Fixed in Version 0.13 => 0.14