View Issue Details

IDProjectCategoryView StatusLast Update
0000827FreeCADBugpublic2012-11-20 17:13
ReporternormandcAssigned Tologari81 
PriorityhighSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version0.13 
Summary0000827: Sketch copy deletes all constraints
DescriptionPreviously when copying a sketch by copy-paste, all constraints and dimensions were copied to the new sketch.

Now this is broken in the latest development release. Only sketch objects are preserved. This is a major usability setback which should be fixed before official release.

Steps to reproduce:
1. Open attached .fcstd file
2. Select Sketch
3. Click on "Copy" in the standard toolbar
4. Click on "Paste" in the standard toolbar
5. Edit the new Sketch001 object. All the constraints are gone.
Additional InformationOS: Ubuntu 12.04.1 LTS
Platform: 64-bit
Version: 0.13.1409 (Git)
Branch: master
Hash: 1d5f4147f1e91de14306339d3e4e83d5cae7b472
Python version: 2.7.3
Qt version: 4.8.1
Coin version: 3.1.3
SoQt version: 1.5.0
OCC version: 6.5.0
TagsNo tags attached.

Activities

2012-09-08 15:22

 

sketch_copy_broken.fcstd (Attachment missing)

normandc

2012-09-08 15:29

manager   ~0002361

The problem actually is older than I thought. I uninstalled FreeCAD and installed the oldest .deb package I had in /var/cache/apt/archives, named freecad_0.13-git201208111837~precise1_amd64.deb. The bug is already there.

normandc

2012-09-08 15:41

manager   ~0002362

Last edited: 2012-09-08 15:44

I remembered I copied a precise PPA package to my UbuntuOne account for a forum member. I installed freecad_0.13-git201208060321~precise1_amd64.deb which is available at this link: http://ubuntuone.com/0qxLGSeraDzwui8W7fm2Oi

About FreeCAD reports the following:
Platform: Ubuntu 12.04.1 LTS (64-bit)
Version: 0.13.1306 (Git)
Branch: master
Hash: eac9182ac95bc62101c33a8bf81957000d645e64
Python version: 2.7.3
Qt version: 4.8.1
Coin version: 3.1.3
SoQt version: 1.5.0
OCC version: 6.5.0
Published date: 2012/07/31


This version does not suffer from the bug.

I wouldn't put too much confidence on the hash and git-commit being the right one, since I manually update this info once a day in the versioning.git launchpad branch.

The bug would then have been introduced between 07/31 and 08/11.

logari81

2012-09-09 18:24

developer   ~0002364

actually the constraints seem to be deleted but they are not deleted, there must be some acceptGeometry() call missing.

normandc

2012-11-20 03:00

manager   ~0002562

Bug is still there.

OS: Ubuntu 12.04.1 LTS
Platform: 64-bit
Version: 0.13.1652 (Git)
Branch: master
Hash: 1ca8f9562dff7783717a4b841d2e23f9459623e4
Python version: 2.7.3
Qt version: 4.8.1
Coin version: 3.1.3
SoQt version: 1.5.0
OCC version: 6.5.0


Actually jriegel mentioned in the forum that using the copy-paste tool was not a good idea.

Should I close this bug and create a request for a specific copy sketch tool to be added to the Sketcher in (hopefully) v0.14?

logari81

2012-11-20 07:19

developer   ~0002564

no, this report shouldn't be closed. It is in my TODO list.

wmayer

2012-11-20 11:19

administrator   ~0002567

This bug is not directly related to the sketcher but when pasting from clipboard for the created sketcher copy the method onDocumentRestored() isn't called and thus acceptGeometry() isn't called either.

wmayer

2012-11-20 11:20

administrator   ~0002568

git show cf49979

logari81

2012-11-20 11:34

developer   ~0002569

just re-openning for adding some more information on this.

yes I was aware that the problem was that OnDocumentRestored wasn't called on paste/merge. Since we use OnDocumentRestored only for the sketcher, my original intention was to get rid of it completely and add some additional logic for handling missing external geometries / references. Anyway if it works now, lets let it for the moment.

Btw we should also remove onFinishDuplicating since it should be replaced with OnDocumentRestored.

Issue History

Date Modified Username Field Change
2012-09-08 15:22 normandc New Issue
2012-09-08 15:22 normandc File Added: sketch_copy_broken.fcstd
2012-09-08 15:29 normandc Note Added: 0002361
2012-09-08 15:41 normandc Note Added: 0002362
2012-09-08 15:43 normandc Note Edited: 0002362
2012-09-08 15:44 normandc Note Edited: 0002362
2012-09-08 15:44 normandc Note Edited: 0002362
2012-09-09 18:21 logari81 Status new => assigned
2012-09-09 18:21 logari81 Assigned To => logari81
2012-09-09 18:24 logari81 Note Added: 0002364
2012-11-20 03:00 normandc Note Added: 0002562
2012-11-20 07:19 logari81 Note Added: 0002564
2012-11-20 11:19 wmayer Note Added: 0002567
2012-11-20 11:20 wmayer Note Added: 0002568
2012-11-20 11:20 wmayer Status assigned => resolved
2012-11-20 11:20 wmayer Fixed in Version => 0.13
2012-11-20 11:20 wmayer Resolution open => fixed
2012-11-20 11:34 logari81 Note Added: 0002569
2012-11-20 11:34 logari81 Status resolved => feedback
2012-11-20 11:34 logari81 Resolution fixed => reopened
2012-11-20 17:13 logari81 Status feedback => closed
2012-11-20 17:13 logari81 Resolution reopened => fixed