View Issue Details

IDProjectCategoryView StatusLast Update
0000819FreeCADBugpublic2016-07-23 10:40
ReporterpperisinAssigned ToJriegel 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.12 
Target VersionFixed in Version0.17 
Summary0000819: Faces colors lost again (sorry)
DescriptionHi,

I have noticed that shapes loose colors on delete. So if you have shape with single color, or with color-per-face, they are lost when you delete object and press undo to undelete object. Undeleted one has default color
Additional InformationWin7 64bit.

Make box,
add color to it (per face, or per solid),
delete object,
press undo to undelete - color lost
TagsNo tags attached.

Relationships

related to 0000020 closedJriegel UndoRedo for Gui Elements 

Activities

wmayer

2012-08-31 09:07

administrator   ~0002333

Last edited: 2012-08-31 09:07

Undo/redp only works on App level but not on Gui level. Thus, face colors cannot be restored any more.

See also #0000020

pperisin

2012-08-31 10:48

reporter   ~0002336

Last edited: 2012-08-31 10:49

OK.

I will suggest something that even to me seems little stupid, but it might be worth considering in order to prevent users from loosing information (their work).

Since it is not finished, maybe additional check can be made before object is deleted - check if object has color-per-face info. if it does, show message that says objects have color-per-face info that will be lost permanently delete.

I know it is a little stupid, especially if you have a lot of objects that can be deleted when you import STEP file and the message would appear every time you click delete (you could select those you want to delete and press del only once, to get only one message).

color-per-model info is not so important, since it is easy to restore it.

Regards,
Petar

Issue History

Date Modified Username Field Change
2012-08-30 10:27 pperisin New Issue
2012-08-31 09:07 wmayer Note Added: 0002333
2012-08-31 09:07 wmayer Note Edited: 0002333
2012-08-31 09:07 wmayer Relationship added related to 0000020
2012-08-31 10:48 pperisin Note Added: 0002336
2012-08-31 10:49 pperisin Note Edited: 0002336
2012-12-20 20:25 Jriegel Status new => assigned
2012-12-20 20:25 Jriegel Assigned To => Jriegel
2012-12-20 20:25 Jriegel Status assigned => confirmed
2016-07-23 10:39 wmayer Changeset attached => FreeCAD Master master f0e00311
2016-07-23 10:40 wmayer Changeset attached => FreeCAD Master master 9ec06b47
2016-07-23 10:40 wmayer Changeset attached => FreeCAD Master master 0f2db906
2016-07-23 10:40 wmayer Changeset attached => FreeCAD Master master f2bad459
2016-07-23 10:40 wmayer Status confirmed => closed
2016-07-23 10:40 wmayer Resolution open => fixed
2016-07-23 10:40 wmayer Fixed in Version => 0.17