View Issue Details

IDProjectCategoryView StatusLast Update
0000817FreeCADBugpublic2012-09-07 10:04
ReporterflelchukAssigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.12 
Target VersionFixed in Version0.13 
Summary0000817: 'make DevDoc' fails
DescriptionI was trying to build the documentation (out of source).
However, there were some issues:

1) CMake ignores the Doc subdirectory unless FREECAD_MAINTAINERS_BUILD is defined:

---

if(FREECAD_MAINTAINERS_BUILD)
    add_subdirectory(Doc)
endif(FREECAD_MAINTAINERS_BUILD)

---

2) The output directory for documentation should be 'doc' not 'Doc' (might work on Win32 but fails on Linux)

Besides, doing 'make SourceDocu' and 'make UserDocu' produces an error, too because QT_HELPCOMPILER_EXECUTABLE is undefined (empty string). It solves the problem to define QT_HELPCOMPILER_EXECUTABLE=qhelpgenerator. (That's not a bug but it should be mentioned somewhere...)

Greetings
Additional InformationI'm providing patches for src/CMakeLists.txt and src/Doc/CMakeLists.txt so you can just go to the repository and type:

$> patch -u -p1 < /path/to/doc1.patch
$> patch -u -p1 < /path/to/doc2.patch
TagsNo tags attached.

Activities

2012-08-28 12:08

 

patch.tgz (Attachment missing)

wmayer

2012-09-07 10:04

administrator   ~0002356

git show ec8c4f2

Issue History

Date Modified Username Field Change
2012-08-28 12:08 flelchuk New Issue
2012-08-28 12:08 flelchuk File Added: patch.tgz
2012-09-07 10:04 wmayer Note Added: 0002356
2012-09-07 10:04 wmayer Status new => closed
2012-09-07 10:04 wmayer Resolution open => fixed
2012-09-07 10:04 wmayer Fixed in Version => 0.13