View Issue Details

IDProjectCategoryView StatusLast Update
0000805FreeCADFeaturepublic2017-01-09 16:09
Reporteren3rgyAssigned Tomrlukeparry 
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Product Version0.12 
Target VersionFixed in Version0.17 
Summary0000805: Add dimensions to drawings
DescriptionThe power of drawings is print outs to easily share with others. Beside the part's form an other realy important information are dimensions.

There should be a way to add dimensions to a drawing - within the drawing view. Snapping to the drawn objects.
TagsNo tags attached.

Activities

jcc242

2012-08-31 04:13

reporter   ~0002332

Last edited: 2012-08-31 04:13

Currently the drawing sheets use SVG elements, is this the best format? I like how easy and portable the format is, but I'm not sure if it is best for technical drawings since you can't set absolute units for a number of the SVG elements (I'm not sure it even works with <line>).

I found this: http://stackoverflow.com/questions/1346922/svg-and-dpi-absolute-units-and-user-units-inkscape-vs-firefox-vs-imagemagick

The solution is rather elegant and would eliminate my concerns except, as pointed out, for the DPI scaling issue. Would this even be a problem since the intent is to print, and the SVG viewer should scale everything correctly for printing? How would this scaling affect line properties (thickness, dashes)?

Of course, if we have nothing to worry about then I could put together some svg dimensions and tolerances if it would be helpful. I only have the NASA spec since that is what I design to, but I believe it is a derivative of ANSI and nearly identical. Perhaps with some small modifications (and a nice Settings dialogue) we can have all 3 specs.

(Sorry if my concerns have been brought up before by others, I haven't seen anything on it.)

yorik

2012-09-02 13:02

administrator   ~0002338

SVG may have its problems, but we're all convinced here that it is the most adequate format for the Drawing module. Your problem with using absolute units inside svg elements is quite well known (there is some discussion on the forum about it IIRC, and also on the inkscape forums) but I'm afraid there is nothing we can do about it on the freecad side...

Probably the best course of action is to try to convince the w3c people. Originally SVG was made for the web, and it is very recent that it begins to be used for tech drawings.

In freecad, for purely technical drawings, you'd better output them as DXF, probably...

To reply the original post submission, that is planned of course, but will probably take some time to be implemented, since several other actions must take place before (switch the Drawing viewer to webkit, etc...)

wmayer

2017-01-09 16:09

administrator   ~0007578

Dimensions are implemented in the new techdraw workbench.

Issue History

Date Modified Username Field Change
2012-07-24 03:57 en3rgy New Issue
2012-08-31 04:13 jcc242 Note Added: 0002332
2012-08-31 04:13 jcc242 Note Edited: 0002332
2012-09-02 13:02 yorik Note Added: 0002338
2013-05-15 06:03 mrlukeparry Status new => assigned
2013-05-15 06:03 mrlukeparry Assigned To => mrlukeparry
2017-01-09 16:09 wmayer Note Added: 0007578
2017-01-09 16:09 wmayer Status assigned => closed
2017-01-09 16:09 wmayer Resolution open => fixed
2017-01-09 16:09 wmayer Fixed in Version => 0.17