View Issue Details

IDProjectCategoryView StatusLast Update
0000768PartDesignBugpublic2017-03-27 08:30
ReporterjmaustpcAssigned Towmayer 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Platform64 bitOSkubuntuOS Version12.04
Product Version 
Target VersionFixed in Version0.14 
Summary0000768: Part Sweep and Loft limitations and bugs
DescriptionPart loft and sweep either not working at all or producing only a surface is many situations.
Steps To ReproduceI wanted to make a dinning room chair back. So I tried 5 different approaches, the first worked but with a face rendered past the end on the ellipse and only the last worked perfectly.

1) I tried to loft from one Part ellipse to another and could only get a surface even with "make solid" ticked
2) as described here [url]https://sourceforge.net/apps/phpbb/free-cad/viewtopic.php?f=10&t=2762[/url] I created a top and bottom ellipse from Part create primitives, then used Part Shape Builder to create a Part Face from the ellipse. The face was longer than the ellipse (a bug), still I lofted (but only got a surface surface) between the two ellipses, then got the two faces from ellipses and the loft surface, then added them together to make a shell in Part Shape Builder, then used Part Shape Builder again to make the shell into a solid. This did work except that the top and bottom ellipses did render to long in the x direction.
3) I made a top sketch and a bottom sketch. Loft between sketches also only made a surface despite having ticked "make solid"
4) then I created a sketch for a path and used Part Sweep with the two ellipses and the sketch for Path, it worked except that is would not make a solid even though "make solid" was ticked, so I only got a surface again.
5) this finally worked, I created a sketch for the top and another for the bottom, then another sketch for the path, I then used Part Sweep from one sketch to the other using the third as the Path and ticked "make solid" which produced a solid. :)
Additional InformationPlatform: Ubuntu 12.04 LTS (64-bit)
Version: 0.13.1212 (Git)
Branch: master
Hash: dfca264acfa6fc7c58d4ca695c5ac76507568073
Python version: 2.7.3
Qt version: 4.8.1
Coin version: 3.1.3
SoQt version: 1.5.0
OCC version: 6.5.0
TagsNo tags attached.

Activities

2012-07-01 05:04

 

dinning_room_chair_render_sweep_loft_problems_examples.FCStd (32,904 bytes)

jmaustpc

2012-07-01 05:07

manager   ~0002252

here is a link to the appropriate forum topic

http://forum.freecadweb.org/viewtopic.php?f=10&t=2763

Jriegel

2012-12-20 20:41

administrator   ~0002708

Its again the limitations of OCC.

wmayer

2013-10-13 07:14

administrator   ~0003741

git show 5a96582 fixes "loft_chair_back_from_sketches". So, only the loft and sweep using the ellipses don't create the expected solid.

wmayer

2013-10-13 07:42

administrator   ~0003742

The loft and sweep doesn't work because the ellipses are not complete. The start angle for all of them is 1 deg so that are not closed and thus a solid cannot be created. After setting the correct start angle everything works perfectly.

Issue History

Date Modified Username Field Change
2012-07-01 05:04 jmaustpc New Issue
2012-07-01 05:04 jmaustpc File Added: dinning_room_chair_render_sweep_loft_problems_examples.FCStd
2012-07-01 05:07 jmaustpc Note Added: 0002252
2012-07-01 12:51 yorik Project FreeCAD => PartDesign
2012-12-20 20:41 Jriegel Note Added: 0002708
2012-12-20 20:41 Jriegel Status new => confirmed
2013-10-13 07:14 wmayer Note Added: 0003741
2013-10-13 07:42 wmayer Note Added: 0003742
2013-10-13 07:42 wmayer Status confirmed => assigned
2013-10-13 07:42 wmayer Assigned To => wmayer
2013-10-13 07:43 wmayer Status assigned => closed
2013-10-13 07:43 wmayer Resolution open => fixed
2013-10-13 07:43 wmayer Fixed in Version => 0.14
2017-03-27 08:30 Kunda1 Changeset attached => FreeCAD master 5a96582a