View Issue Details

IDProjectCategoryView StatusLast Update
0000556FreeCADBugpublic2011-12-31 18:21
ReporterJriegelAssigned Toyorik 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.12 
Target VersionFixed in Version0.13 
Summary0000556: Premature loading of modules
DescriptionIn InitGui.py of the draft Workbench the module DraftTools get loaded
and with it the whole Part module. This slows down startup of FreeCAD
considerable! Since Start is default no module must be premature loaded.
TagsNo tags attached.

Activities

yorik

2011-12-31 12:35

administrator   ~0001524

Hm good catch indeed, I hadn't thought about that... I'll fix that!

yorik

2011-12-31 18:21

administrator   ~0001530

Done for Draft and Arch! Appearently no more module are loaded at init time now...

Issue History

Date Modified Username Field Change
2011-12-31 00:05 Jriegel New Issue
2011-12-31 00:05 Jriegel Status new => assigned
2011-12-31 00:05 Jriegel Assigned To => yorik
2011-12-31 00:08 Jriegel Product Version 0.11 => 0.12
2011-12-31 12:35 yorik Note Added: 0001524
2011-12-31 18:21 yorik Note Added: 0001530
2011-12-31 18:21 yorik Status assigned => closed
2011-12-31 18:21 yorik Resolution open => fixed
2011-12-31 18:21 yorik Fixed in Version => 0.13