View Issue Details

IDProjectCategoryView StatusLast Update
0000555FreeCADFeaturepublic2012-01-01 11:47
ReportermicrotorchAssigned To 
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionfixed 
Product Version0.11 
Target VersionFixed in Version0.13 
Summary0000555: 3D navigation using a two-button laptop touchpad
DescriptionHi all,
 
I am using FreeCAD v0.12 revision 5284 on an MSI M670 laptop running Vista 32bit.
 
I would like to be able to use FreeCAD with the built-in touchpad rather than having to use a separate mouse. The M670 touchpad has two buttons and a scroll area to the right so zoom is fine. However, it does not have a way to do middle mouse button click or hold. Holding Left and Right buttons down together does not work, so I am really stuck. Could you consider adding a specific 3D Navigation option for this type of Touchpad? My suggestion on control mapping is as follows.
 
Select: Left mouse button.
Pan: Holding shift down whilst moving mouse causes view to pan.
Rotate: Holding Shift+Ctrl down whilst moving the mouse causes view to rotate.
Zoom: Scroll up = Zoom-in, scroll down = Zoom-out.
 
Rob
TagsNo tags attached.

Activities

wmayer

2011-12-31 13:45

administrator   ~0001525

Last edited: 2011-12-31 14:34

Using a touch pad is the same as having a two-button mouse. To have full control switch to Inventor navigation and use this setting:

Rotating == Left mouse button
Panning == Shift + Left mouse button
Selection == Ctrl + Left mouse button

For zooming in/out our default is Ctrl + +/-. However, under Tools>Customize you can use PgUp/PgDn instead.

Alternatively, I'll also implement Shift+Ctrl+Right mouse button for zooming. For CAD and Blender navigation this is already used but not for Inventor.

microtorch

2011-12-31 14:53

reporter   ~0001526

Sorry, I should have mentioned that I already tried the Inventor navigation out. The problem is it doesn't allow you to select additional objects from the 3D view (because Ctrl + Left Mouse Button is now Select). My suggestion retains the use of Left Mouse Button for selection and Ctrl + Left Mouse Button to add to the selection. There is no problem with zooming (on my touchpad at least) so perhaps you could reconsider my original suggestion.

wmayer

2011-12-31 16:35

administrator   ~0001527

So, if I got you right the only problem you have is the multi-selection. That's indeed not possible with the Inventor style.

Your feature request should be pretty simple to implement but I just wanted to point out that with the current implementation (besides multi-selection) everything can be done with the Inventor style already.

microtorch

2011-12-31 16:54

reporter   ~0001528

Yes, I was using the Inventor navigation for a while, but the multi-selection was the show-stopper.

wmayer

2012-01-01 11:47

administrator   ~0001531

Added in rev 5373

Additional alternatives:
Rotate: ALT + move
Zoom: CTRL + SHIFT + LMB + move

Issue History

Date Modified Username Field Change
2011-12-30 12:04 microtorch New Issue
2011-12-31 13:45 wmayer Note Added: 0001525
2011-12-31 14:33 wmayer Note Edited: 0001525
2011-12-31 14:34 wmayer Note Edited: 0001525
2011-12-31 14:34 wmayer Note Edited: 0001525
2011-12-31 14:53 microtorch Note Added: 0001526
2011-12-31 16:35 wmayer Note Added: 0001527
2011-12-31 16:54 microtorch Note Added: 0001528
2012-01-01 11:47 wmayer Note Added: 0001531
2012-01-01 11:47 wmayer Status new => closed
2012-01-01 11:47 wmayer Resolution open => fixed
2012-01-01 11:47 wmayer Fixed in Version => 0.13