View Issue Details

IDProjectCategoryView StatusLast Update
0000549FreeCADBugpublic2011-12-25 18:54
ReportersliptonicAssigned Toyorik 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version0.13 
Summary0000549: Undo of offset objects causes Draft tools to stop functioning.
DescriptionSVN 5328 on Linux Mint 'Lisa'

I've marked this error as always repeatable and it is, for me, using the following steps. Other combinations of object selection/deselection or manipulation give me intermittent results.

Open a new document and switch to the Draft workbench.
Click the 'create regular polygon' tool
Click on the canvas and drag it out to a radius of 1.0 or so.
Without selecting the polygon, click the 'offset active object' tool.
Immediately click the 'undo' button.

For me, the polygon has now disappeared and it is not possible to draw anything on the canvas except a point. Only closing FreeCAD and restarting it resolves the problem.
Additional InformationOnce the problem occurs, this is shown in the console repeatedly:


<type 'exceptions.RuntimeError'>
Traceback (most recent call last):
  File "/home/brad/freecad/Mod/Draft/DraftTools.py", line 740, in action
    point,ctrlPoint = getPoint(self,arg,mobile=True)
  File "/home/brad/freecad/Mod/Draft/DraftTools.py", line 156, in getPoint
    else: ui.displayPoint(point, plane=plane, mask=mask)
  File "/home/brad/freecad/Mod/Draft/DraftGui.py", line 932, in displayPoint
    if self.isRelative.isChecked() and (last != None):
RuntimeError: underlying C/C++ object has been deleted
TagsNo tags attached.

Activities

yorik

2011-12-20 19:49

administrator   ~0001503

Indeed I can confirm that. It doesn't seem to happen when the Draft module is in Taskview mode, though. I'll investigate...

yorik

2011-12-25 18:54

administrator   ~0001513

This is now fixed with a workaround.

Since it is not possible to prevent undoing while in Taskmode, and nothing should prevent you from undoing any previous operation and finding yourself with no object in the document, I simply removed the possibility to use the Draft modifier tools if no object is selected.
That feature was broken since a very long time, and nobody complained, so I suppose nobody was using it anyway.

This now prevent finding yourself in the situation reported above, and also solves the side problem of the error messages appearing.

Issue History

Date Modified Username Field Change
2011-12-20 13:25 sliptonic New Issue
2011-12-20 19:49 yorik Note Added: 0001503
2011-12-20 19:49 yorik Status new => assigned
2011-12-20 19:49 yorik Assigned To => yorik
2011-12-25 18:54 yorik Note Added: 0001513
2011-12-25 18:54 yorik Status assigned => closed
2011-12-25 18:54 yorik Resolution open => fixed
2011-12-25 18:54 yorik Fixed in Version => 0.13