View Issue Details

IDProjectCategoryView StatusLast Update
0000548FreeCADFeaturepublic2012-01-04 15:18
ReporterjmaustpcAssigned Towmayer 
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version0.13 
Summary0000548: 3D Circle from three points in Part wb
DescriptionHi Werner

I made a 3D Circle from three points in Part wb create primitives dialogue.

I now trying to make a better tool of it by placing buttons in the GUI that function the same way as the 3d view button for the placement works.

One example of a use for the tool is a simple way of correctly locating a circle or a part of a circle, on the the vertices of a shape converted from an imported STL's cross section.

I suggest that for now I leave it in the create primitives dialogue, but I could move it into a separate tool, or some other place.

I haven't attached the code yet, I was waiting until I get the buttons worked out.

Any thoughts?

Jim
TagsNo tags attached.

Activities

wmayer

2011-12-19 15:05

administrator   ~0001496

Then maybe we should think about to make this even more flexible. A circle can be created in many ways:
* center + radius
* three points on the shape
* center + point on shape
* ...

So, the new tool should be able to support all these methods and should also be easily extendible for further methods.

This could also be done for other primitives.

I think we have to re-implement the current primitive dialog and make it also a task panel. This is needed to improve user interactions because the dialog as it is now covers a big area of the 3d view which is somewhat annoying then.

If you like you can implement your function using the dialog as it is now and I will apply your idea to the task dialog when it's done.

jmaustpc

2011-12-19 16:17

manager   ~0001499

<<If you like you can implement your function using the dialog as it is now and I will apply your idea to the task dialog when it's done. >>

OK, Yes I think this is the best way to since that way the functions are there and usable but can be improve over time.

I can do the above easily with different items that make the different circles but the created circles will only be parametric based on the parameters that were used to create each different one. Is this what you mean? Or at least on a "will do for now" basis? If you mean this way I could do that for all the shapes.

Or do you want only one type of circle to be created (no matter the method) with every possible and conflicting parameter displayed and editable? This would presumably be like Yorik's Polar/ortho array tool's parameters.

jmaustpc

2011-12-19 16:25

manager   ~0001500

I can see why you are going to Tasks and accept it, but I must admit I actually like the old dialogue. Its very solid reliable bug free, can be resized moved out of the way, put on a second monitor. I like the 3d view tool because it will only find a location on an existing shape, great when that's what you want, but I suppose a pain if you just want to select somewhere in empty 3d space.

wmayer

2011-12-19 16:43

administrator   ~0001501

> I can do the above easily with different items that make the different circles but the created circles will only be parametric based on the parameters that were used to create each different one. Is this what you mean? Or at least on a "will do for now" basis? If you mean this way I could do that for all the shapes.

If this is not something you must have right now it would be better to wait until the task dialog is done because otherwise it only leads to double work.

> I can see why you are going to Tasks and accept it, but I must admit I actually like the old dialogue. Its very solid reliable bug free, can be resized moved out of the way, put on a second monitor. I like the 3d view tool because it will only find a location on an existing shape, great when that's what you want, but I suppose a pain if you just want to select somewhere in empty 3d space.

But there are two reasons to have a task panel.
1. it doesn't cause a redraw of the 3d view
2. it is annoying for users who often has some interactions with 3d view if they always have to move the dialog to somewhere else.

wmayer

2011-12-20 09:57

administrator   ~0001502

I looked at your new patch and I saw you had implemented a feature Circle3Pnt but I didn't mean to implement the different ways of creating a circle on feature-basis. On this level we have only one class "Circle" (see FeaturePartCircle.cpp) that must stay as is. The different ways of creating the circle must be done by the dialog. Depending on the input the dialog gets from the user it has to "convert" this information to compute the circle based on radius, angles and placement.

jmaustpc

2011-12-21 11:32

manager   ~0001506

OK will do :-)

wmayer

2012-01-04 15:18

administrator   ~0001539

Added in rev 5387

Issue History

Date Modified Username Field Change
2011-12-19 14:34 jmaustpc New Issue
2011-12-19 15:05 wmayer Note Added: 0001496
2011-12-19 16:17 jmaustpc Note Added: 0001499
2011-12-19 16:25 jmaustpc Note Added: 0001500
2011-12-19 16:43 wmayer Note Added: 0001501
2011-12-20 09:57 wmayer Note Added: 0001502
2011-12-20 09:57 wmayer Status new => assigned
2011-12-20 09:57 wmayer Assigned To => wmayer
2011-12-21 11:32 jmaustpc Note Added: 0001506
2012-01-04 15:18 wmayer Note Added: 0001539
2012-01-04 15:18 wmayer Status assigned => closed
2012-01-04 15:18 wmayer Resolution open => fixed
2012-01-04 15:18 wmayer Fixed in Version => 0.13