View Issue Details

IDProjectCategoryView StatusLast Update
0000538FreeCADBugpublic2013-07-10 11:43
ReporterjmaustpcAssigned Towmayer 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version0.14 
Summary0000538: Part WB extrude from ruled surface makes either two faces or a solid
DescriptionIn Part WB extrude from rulled surface makes either two faces or a solid depending on how one created the ruled surface.

In Part create 4 vertices, build 4 edges from vertices, then

1) if select two adjacent edges of square (at 90 deg to each other with one common vertex) seems to work and creates a "filled solid". Now extrude just extrudes the two edges producing an "L" shape of two faces at 90 degs to each other

2) if select two opposite edges of square it also seems to produce the same thing, "filled shape". Now extrude produces a cuboid.
TagsNo tags attached.

Activities

2011-12-12 02:05

 

Partwblackoftreestructuremirrorandruledsurface.jpeg (Attachment missing)

2011-12-12 02:07

 

Partwblackoftreestructuremirrorandruledsurface.FCStd (Attachment missing)

wmayer

2011-12-15 15:35

administrator   ~0001484

> 1) if select two adjacent edges of square (at 90 deg to each other with one common vertex) seems to work and creates a "filled solid". Now extrude just extrudes the two edges producing an "L" shape of two faces at 90 degs to each other

No, it doesn't create a filled shape even though it claims in the tree view. But the point is that the two edges must not have a common vertex because otherwise the face has a singularity at this point and thus is broken.

jmaustpc

2011-12-17 05:29

manager   ~0001489

Last edited: 2011-12-17 05:31

How does the software get around this issue with triangular faces?

For example one of the faces of a pyramid or one of the triangular faces of a solid created from a mesh?

wmayer

2013-07-10 11:42

administrator   ~0003374

The ruled surface feature has the property 'Orientation' with the possible values: Automatic (default), Forward and Reversed. In cases like this you have to manually set to Reversed to create the triangle.

Issue History

Date Modified Username Field Change
2011-12-12 02:05 jmaustpc New Issue
2011-12-12 02:05 jmaustpc File Added: Partwblackoftreestructuremirrorandruledsurface.jpeg
2011-12-12 02:07 jmaustpc File Added: Partwblackoftreestructuremirrorandruledsurface.FCStd
2011-12-15 15:35 wmayer Note Added: 0001484
2011-12-17 05:29 jmaustpc Note Added: 0001489
2011-12-17 05:31 jmaustpc Note Edited: 0001489
2013-07-10 11:42 wmayer Note Added: 0003374
2013-07-10 11:42 wmayer Status new => assigned
2013-07-10 11:42 wmayer Assigned To => wmayer
2013-07-10 11:43 wmayer Status assigned => closed
2013-07-10 11:43 wmayer Resolution open => fixed
2013-07-10 11:43 wmayer Fixed in Version => 0.14