View Issue Details

IDProjectCategoryView StatusLast Update
0000537FreeCADBugpublic2012-06-13 08:58
ReporterjmaustpcAssigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version0.13 
Summary0000537: lack of tree structure in combo view - when using mirror
Descriptionin Part
select a shape
click mirror

the mirrored shape is parametric based on the original shape, but the two are not shown in an expandable tree structure, like one gets with fuse/extrude/etc.
TagsNo tags attached.

Activities

2011-12-12 01:55

 

Partwblackoftreestructuremirrorandruledsurface.jpeg (Attachment missing)

2011-12-12 01:56

 

Partwblackoftreestructuremirrorandruledsurface.FCStd (Attachment missing)

wmayer

2011-12-13 09:56

administrator   ~0001471

IMO the mirror object should NOT regard the referenced object as a child. For many modelling tasks you make a mirrored object and then afterwards you use both for a boolean operation. That's why IMO both objects should be on the same level in the tree structure.

jmaustpc

2011-12-13 10:45

manager   ~0001472

Hi Werner
Am I understanding you correctly? (I mean there is nothing wrong with what you wrote, there is just a problem with my understanding of it :-) )

Are you saying that "mirror" should work like this: - in effect make a new independent item which is a COPY of the original item, except with mirrored parameter values?

So once created the "mirrored copied item" becomes completely independent of the original?

Then should it still be parametric, but based on its own parameters' now independently editable values, (not the matching mirrored values from the original)? In other words, once created one could modify the new "originally mirrored" item's parameters so that it then becomes something different rather than just a mirror copy of the original?

Or do you think it should be more like when using "simple copy" where the resultant copy is not parametric?

wmayer

2011-12-13 11:30

administrator   ~0001473

IMO it's a wrong understanding that in all cases it should be visible (by ordering the tree items underneath) that there is a relation between two objects.
In a lot of case it makes sense like pad, pocket, fillet but IMO not for mirroring.

> Are you saying that "mirror" should work like this: - in effect make a new independent item which is a COPY of the original item, except with mirrored parameter values?

No. The mirror object still has the reference to the original, its mirroring parameters and compute a new shape from these information. So, the mirror object is definitely not independent from the base object.

jmaustpc

2011-12-13 11:48

manager   ~0001474

OK I think I understand now, but that brings up another slightly different question then,

How should we indicated which mirror relates to which original? This is probably not used enough to get too confusing, but a similar situation comes up with inter related sketches and objects in partdesign. It can be hard to see at a glace which sketch is attached to what face etc. I thought the simplest resolution is to in both cases just order the tree items. Can you think of an alternative method to visually link interrelated items?

wmayer

2011-12-13 12:14

administrator   ~0001475

Maybe we should have a special widget that shows the relations between objects. The tree view is only partially useful for this. Also because an object can be referenced by more than one object but the tree view is not capable of showing this. So, IMO a special widget showing the dependencies is probably the best solution.

jmaustpc

2011-12-13 13:49

manager   ~0001476

Yes, I had exactly that problem with some of my more complex designs in Part.

The shared item is under both trees but only can be seen at one location at a time. Didn't show up in other locations unless you expand the tree for the second location, and then of course the first location tree closes.

This worked but was a little annoying and cumbersome.

At the time I was wondering if it would be better to just show all the instances in all locations, but have them all high light when any one was clicked on, and perhaps have the high light a different colour to warn you of this, for when your tree structure is to large to see the second third ...or whatever number other copies?

Actually I suppose when duplicated the items could be permanently coloured as though they were high lighted but in a different colour (and perhapes cross-hatched) and then highlight again with the normal green high light colour over the top when the item (and hence its duplicates) are actively selected.

wmayer

2012-06-13 08:58

administrator   ~0002196

Showing the dependencies of objects in a special Qt widgets is very difficult because the relations an be very complex.

There is now a command in the Tools menu which shows an image all the relations. You therefore need Graphviz installed on your system.

git show 3259a16

Issue History

Date Modified Username Field Change
2011-12-12 01:55 jmaustpc New Issue
2011-12-12 01:55 jmaustpc File Added: Partwblackoftreestructuremirrorandruledsurface.jpeg
2011-12-12 01:56 jmaustpc File Added: Partwblackoftreestructuremirrorandruledsurface.FCStd
2011-12-13 09:56 wmayer Note Added: 0001471
2011-12-13 10:45 jmaustpc Note Added: 0001472
2011-12-13 11:30 wmayer Note Added: 0001473
2011-12-13 11:48 jmaustpc Note Added: 0001474
2011-12-13 12:14 wmayer Note Added: 0001475
2011-12-13 13:49 jmaustpc Note Added: 0001476
2012-06-13 08:58 wmayer Note Added: 0002196
2012-06-13 08:58 wmayer Status new => closed
2012-06-13 08:58 wmayer Resolution open => fixed
2012-06-13 08:58 wmayer Fixed in Version => 0.13