View Issue Details

IDProjectCategoryView StatusLast Update
0000519FreeCADPatchpublic2011-12-11 11:37
Reporterhobbes1069Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version0.11 
Target VersionFixed in Version0.13 
Summary0000519: Patch to set proper RPATH's for system wide installation on Linux.
DescriptionPatch submission related to:
https://sourceforge.net/apps/phpbb/free-cad/viewtopic.php?f=8&t=1954&start=20#p13497

The patch in the forum is now obsolete and a new patch attached here.

This also fixes a few nit picks such as:
- Properly set CMAKE_INSTALL_PREFIX for UNIX.
- Set RPATH on all libraries and binaries since their dependencies are not located in the standard search path.
- Add DOCDIR and RESOURCEDIR cmake options.
- Create missing CMakeLists.txt for src/Mod/Start/StartPage
TagsNo tags attached.

Activities

2011-12-05 23:29

 

freecad-system_inst.patch (Attachment missing)

wmayer

2011-12-11 11:37

administrator   ~0001462

Applied with rev 5270

Issue History

Date Modified Username Field Change
2011-12-05 23:29 hobbes1069 New Issue
2011-12-05 23:29 hobbes1069 File Added: freecad-system_inst.patch
2011-12-11 11:37 wmayer Note Added: 0001462
2011-12-11 11:37 wmayer Status new => closed
2011-12-11 11:37 wmayer Resolution open => fixed
2011-12-11 11:37 wmayer Fixed in Version => 0.13