View Issue Details

IDProjectCategoryView StatusLast Update
0000508FreeCADBugpublic2011-12-05 14:42
ReportertilasAssigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version0.13 
Summary0000508: Part: Parameterized Primitive: Plane - new planes with normals x or y are placed wrong
DescriptionThe new plane definition requires the normal direction, coordinates of the origin and length width dimensions.
The coordinates accept both positive and negative values whereas the L&W only positive. IMHO, it is expected that the L&W grow in the corresponding positive directions.
Example:
plane with normal "z", Origin at (-5,-5,0) and W=10, L=10 is placed at
-5<x<5, -5<y<5, z=0. This is expected and what is actually happening now. It follows that a plane with normal 'x', Origin at (0,-5,-5) and W=10,L=10 should be placed at x=0, -5<y<5, -5<z<5. However it is currently placed at
x=0, -5<y<5, -15<z<-5, which is quite an unexpected location. The same happens with a new plane with normal 'y' - it gets placed at
-5<x<5, y=0, -15<z<-5...

The problem seems to be an incorrect rotation of the base plane. To see this, leave the origin at (0,0,0) and make the L&W not equal, say L=10, W=20 and create the three planes.
TagsNo tags attached.

Activities

wmayer

2011-12-05 13:41

administrator   ~0001396

Last edited: 2011-12-05 13:42

It appeared to be a matter of the internally calculated placement, especially its rotation part. The point is mathematically there is not a unique rotation that describes a rotation from (0,0,1) to (1,0,0). The most obvious way is to rotate around the y-axis by 90 deg. But obviously this leads to this "misbehaviour" of the plane.

The correct way is to do it exactly the same way as with the sketcher drawing plane. So, in this case it's the rotation around (1,1,1) by 120 deg.

wmayer

2011-12-05 14:42

administrator   ~0001397

Fixed in 5221

Issue History

Date Modified Username Field Change
2011-12-04 15:54 tilas New Issue
2011-12-05 13:41 wmayer Note Added: 0001396
2011-12-05 13:42 wmayer Note Edited: 0001396
2011-12-05 14:42 wmayer Note Added: 0001397
2011-12-05 14:42 wmayer Status new => closed
2011-12-05 14:42 wmayer Resolution open => fixed
2011-12-05 14:42 wmayer Fixed in Version => 0.13