View Issue Details

IDProjectCategoryView StatusLast Update
0000507FreeCADFeaturepublic2011-12-12 13:27
ReportertilasAssigned Towmayer 
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version0.13 
Summary0000507: Part/Part Design: allow edge preselection for chamfer/fillet
DescriptionTo make a fillet/chamfer, one needs now to check the checkbox in the list of edges. However without simultaneous edge highlighting - it's difficult to know the edge number (one needs to select the edge and check its ID in the python console).

It might be more convenient if
1. if the user selects an edge(s) prior to hitting the chamfer/fillet icon - only the selected edges will be listed (or pre-checked).
2. when a checkbox is checked - the corresponding edge gets highlighted.

Thanks
TagsNo tags attached.

Activities

wmayer

2011-12-05 12:26

administrator   ~0001390

To 1.) OK we can do it this way, too. But it is already possible to select the edges in the 3d after the fillet/chamfer dialog is open. It automatically selects the right check-box and make it also visible.

T0 2.) This seems to be broken, In former version it only highlighted the edge and not the complete model. I guess this has to do with the new selection node class.

danielfalck

2011-12-09 21:29

reporter   ~0001431

The dialog for filleting in Part Design seems to be broken.After I select some edges on a cube and then press the Fillet icon, the only part of the dialog that comes up is for radius. There is no info on edges available. If I press OK, 'Failed to create fillet' appears in the Report View and there is no object created.
I am using R5246 on Ubuntu 10.04 64 bit.

2011-12-09 21:29

 

missing dialog.png (Attachment missing)

danielfalck

2011-12-09 21:31

reporter   ~0001432

by the way, chamfering does work

wmayer

2011-12-10 20:16

administrator   ~0001457

@Dan, yes I can confirm this.
@tilas, 2) of your request works again

wmayer

2011-12-12 13:27

administrator   ~0001470

Done in rev 5275

Issue History

Date Modified Username Field Change
2011-12-04 15:07 tilas New Issue
2011-12-05 12:26 wmayer Note Added: 0001390
2011-12-05 12:27 wmayer Status new => assigned
2011-12-05 12:27 wmayer Assigned To => wmayer
2011-12-09 21:29 danielfalck Note Added: 0001431
2011-12-09 21:29 danielfalck File Added: missing dialog.png
2011-12-09 21:31 danielfalck Note Added: 0001432
2011-12-10 20:16 wmayer Note Added: 0001457
2011-12-12 13:27 wmayer Note Added: 0001470
2011-12-12 13:27 wmayer Status assigned => closed
2011-12-12 13:27 wmayer Resolution open => fixed
2011-12-12 13:27 wmayer Fixed in Version => 0.13