View Issue Details

IDProjectCategoryView StatusLast Update
0000496FreeCADBugpublic2012-03-01 09:01
ReportercfdfriendAssigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.11 
Target VersionFixed in Version0.13 
Summary0000496: libSketcherGui.so.2: undefined symbol: _ZTIN8Sketcher12SketchObjectE
DescriptionAfter compilation of FreeCAD 0.11 R4652 on Ubuntu 11.10 from a fresh SVN checkout, I'm unable to start the Sketcher Workbench (as well as PartDesign). The application complains about the symbol "_ZTIN8Sketcher12SketchObjectE" being not defined.
When using the HEAD revision of the SVN, a similar error occurs. It is then not complaining about "SketchObject" but about "PropertyConstraintList::_emptyValueList" being undefined.
Additional InformationThe symbols in question are defined in libSketcher.so. But libSketcher.so does not seem to be linked to libSketcherGui.so, "ldd libSketcherGui.so" gives:
schleppi:Sketcher$ ldd libSketcherGui.so
    linux-vdso.so.1 => (0x00007fffceb69000)
    libSoQt4.so.20 => /opt/occlink/Linux/lib/libSoQt4.so.20 (0x00007ffd9c5d6000)
    libCoin.so.60 => /opt/occlink/Linux/lib/libCoin.so.60 (0x00007ffd9bb6d000)
    libQtCore.so.4 => /usr/lib/x86_64-linux-gnu/libQtCore.so.4 (0x00007ffd9b690000)
    libQtGui.so.4 => /usr/lib/x86_64-linux-gnu/libQtGui.so.4 (0x00007ffd9a9b0000)
    libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007ffd9a793000)
    libboost_system.so.1.46.1 => /opt/occlink/Linux/lib/libboost_system.so.1.46.1 (0x00007ffd9a58f000)
    libboost_signals.so.1.46.1 => /opt/occlink/Linux/lib/libboost_signals.so.1.46.1 (0x00007ffd9a37a000)
    libpython2.7.so.1.0 => /opt/occlink/Linux/lib/libpython2.7.so.1.0 (0x00007ffd99e7e000)
    libTKernel-6.5.0.so => /opt/occlink/Linux/lib/libTKernel-6.5.0.so (0x00007ffd99a48000)
    libTKG3d-6.5.0.so => /opt/occlink/Linux/lib/libTKG3d-6.5.0.so (0x00007ffd99744000)
    libTKMath-6.5.0.so => /opt/occlink/Linux/lib/libTKMath-6.5.0.so (0x00007ffd993eb000)
    libTKBRep-6.5.0.so => /opt/occlink/Linux/lib/libTKBRep-6.5.0.so (0x00007ffd99120000)
    libFreeCADBase.so.2 => /home/hannes/Programme/freecad-bin/lib/libFreeCADBase.so.2 (0x00007ffd98df2000)
    libFreeCADApp.so.2 => /home/hannes/Programme/freecad-bin/lib/libFreeCADApp.so.2 (0x00007ffd98ac1000)
    libFreeCADGui.so.2 => /home/hannes/Programme/freecad-bin/lib/libFreeCADGui.so.2 (0x00007ffd98176000)
    libPart.so.2 => /home/hannes/Programme/freecad-bin/Mod/Part/libPart.so.2 (0x00007ffd97d75000)
    libPartGui.so.2 => /home/hannes/Programme/freecad-bin/Mod/Part/libPartGui.so.2 (0x00007ffd97aa6000)
    libstdc++.so.6 => /usr/lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007ffd9779f000)
    libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007ffd9751a000)
    libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007ffd9717b000)
    libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007ffd96f65000)
    libQtOpenGL.so.4 => /usr/lib/x86_64-linux-gnu/libQtOpenGL.so.4 (0x00007ffd96c74000)
    libXi.so.6 => /usr/lib/x86_64-linux-gnu/libXi.so.6 (0x00007ffd96a64000)
    libGL.so.1 => /usr/lib/nvidia-current/libGL.so.1 (0x00007ffd96753000)
    libX11.so.6 => /usr/lib/x86_64-linux-gnu/libX11.so.6 (0x00007ffd9641a000)
    libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007ffd96216000)
    libz.so.1 => /lib/x86_64-linux-gnu/libz.so.1 (0x00007ffd95ffe000)
    libgthread-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgthread-2.0.so.0 (0x00007ffd95df8000)
    librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007ffd95bf0000)
    libglib-2.0.so.0 => /lib/x86_64-linux-gnu/libglib-2.0.so.0 (0x00007ffd958fa000)
    libfontconfig.so.1 => /usr/lib/x86_64-linux-gnu/libfontconfig.so.1 (0x00007ffd956c3000)
    libaudio.so.2 => /usr/lib/x86_64-linux-gnu/libaudio.so.2 (0x00007ffd954aa000)
    libpng12.so.0 => /lib/x86_64-linux-gnu/libpng12.so.0 (0x00007ffd95283000)
    libfreetype.so.6 => /usr/lib/x86_64-linux-gnu/libfreetype.so.6 (0x00007ffd94fea000)
    libgobject-2.0.so.0 => /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0 (0x00007ffd94d99000)
    libSM.so.6 => /usr/lib/x86_64-linux-gnu/libSM.so.6 (0x00007ffd94b91000)
    libICE.so.6 => /usr/lib/x86_64-linux-gnu/libICE.so.6 (0x00007ffd94976000)
    libXrender.so.1 => /usr/lib/x86_64-linux-gnu/libXrender.so.1 (0x00007ffd9476b000)
    libXext.so.6 => /usr/lib/x86_64-linux-gnu/libXext.so.6 (0x00007ffd94558000)
    /lib64/ld-linux-x86-64.so.2 (0x00007ffd9caf4000)
    libssl.so.1.0.0 => /lib/x86_64-linux-gnu/libssl.so.1.0.0 (0x00007ffd94306000)
    libcrypto.so.1.0.0 => /lib/x86_64-linux-gnu/libcrypto.so.1.0.0 (0x00007ffd93f57000)
    libutil.so.1 => /lib/x86_64-linux-gnu/libutil.so.1 (0x00007ffd93d54000)
    libTKG2d-6.5.0.so => /opt/occlink/Linux/lib/libTKG2d-6.5.0.so (0x00007ffd93aec000)
    libTKGeomBase-6.5.0.so => /opt/occlink/Linux/lib/libTKGeomBase-6.5.0.so (0x00007ffd934d4000)
    libboost_regex.so.1.46.1 => /opt/occlink/Linux/lib/libboost_regex.so.1.46.1 (0x00007ffd931d1000)
    libxerces-c.so.28 => /opt/occlink/Linux/lib/libxerces-c.so.28 (0x00007ffd92c1b000)
    libboost_filesystem.so.1.46.1 => /opt/occlink/Linux/lib/libboost_filesystem.so.1.46.1 (0x00007ffd929fd000)
    libboost_program_options.so.1.46.1 => /opt/occlink/Linux/lib/libboost_program_options.so.1.46.1 (0x00007ffd92797000)
    libQtNetwork.so.4 => /usr/lib/x86_64-linux-gnu/libQtNetwork.so.4 (0x00007ffd92457000)
    libQtSvg.so.4 => /usr/lib/x86_64-linux-gnu/libQtSvg.so.4 (0x00007ffd921fe000)
    libQtXml.so.4 => /usr/lib/x86_64-linux-gnu/libQtXml.so.4 (0x00007ffd91fba000)
    libTKFillet-6.5.0.so => /opt/occlink/Linux/lib/libTKFillet-6.5.0.so (0x00007ffd91b63000)
    libTKMesh-6.5.0.so => /opt/occlink/Linux/lib/libTKMesh-6.5.0.so (0x00007ffd918e0000)
    libTKSTEP-6.5.0.so => /opt/occlink/Linux/lib/libTKSTEP-6.5.0.so (0x00007ffd91470000)
    libTKSTEPAttr-6.5.0.so => /opt/occlink/Linux/lib/libTKSTEPAttr-6.5.0.so (0x00007ffd911c8000)
    libTKSTEPBase-6.5.0.so => /opt/occlink/Linux/lib/libTKSTEPBase-6.5.0.so (0x00007ffd90d52000)
    libTKIGES-6.5.0.so => /opt/occlink/Linux/lib/libTKIGES-6.5.0.so (0x00007ffd907c2000)
    libTKSTL-6.5.0.so => /opt/occlink/Linux/lib/libTKSTL-6.5.0.so (0x00007ffd905a3000)
    libTKShHealing-6.5.0.so => /opt/occlink/Linux/lib/libTKShHealing-6.5.0.so (0x00007ffd90194000)
    libTKXSBase-6.5.0.so => /opt/occlink/Linux/lib/libTKXSBase-6.5.0.so (0x00007ffd8fd32000)
    libTKBool-6.5.0.so => /opt/occlink/Linux/lib/libTKBool-6.5.0.so (0x00007ffd8f7c9000)
    libTKBO-6.5.0.so => /opt/occlink/Linux/lib/libTKBO-6.5.0.so (0x00007ffd8f3ff000)
    libTKTopAlgo-6.5.0.so => /opt/occlink/Linux/lib/libTKTopAlgo-6.5.0.so (0x00007ffd8f001000)
    libTKGeomAlgo-6.5.0.so => /opt/occlink/Linux/lib/libTKGeomAlgo-6.5.0.so (0x00007ffd8e7a8000)
    libTKOffset-6.5.0.so => /opt/occlink/Linux/lib/libTKOffset-6.5.0.so (0x00007ffd8e4a1000)
    libTKPrim-6.5.0.so => /opt/occlink/Linux/lib/libTKPrim-6.5.0.so (0x00007ffd8e24d000)
    libnvidia-tls.so.280.13 => /usr/lib/nvidia-current/tls/libnvidia-tls.so.280.13 (0x00007ffd8e049000)
    libnvidia-glcore.so.280.13 => /usr/lib/nvidia-current/libnvidia-glcore.so.280.13 (0x00007ffd8c1fd000)
    libxcb.so.1 => /usr/lib/x86_64-linux-gnu/libxcb.so.1 (0x00007ffd8bfe0000)
    libpcre.so.3 => /lib/x86_64-linux-gnu/libpcre.so.3 (0x00007ffd8bda4000)
    libexpat.so.1 => /lib/x86_64-linux-gnu/libexpat.so.1 (0x00007ffd8bb79000)
    libXt.so.6 => /usr/lib/x86_64-linux-gnu/libXt.so.6 (0x00007ffd8b914000)
    libXau.so.6 => /usr/lib/x86_64-linux-gnu/libXau.so.6 (0x00007ffd8b711000)
    libffi.so.6 => /usr/lib/x86_64-linux-gnu/libffi.so.6 (0x00007ffd8b508000)
    libuuid.so.1 => /lib/x86_64-linux-gnu/libuuid.so.1 (0x00007ffd8b303000)
    libicuuc.so.44 => /opt/occlink/Linux/lib/libicuuc.so.44 (0x00007ffd8afba000)
    libicui18n.so.44 => /opt/occlink/Linux/lib/libicui18n.so.44 (0x00007ffd8abfc000)
    libgomp.so.1 => /usr/lib/x86_64-linux-gnu/libgomp.so.1 (0x00007ffd8a9ed000)
    libTKSTEP209-6.5.0.so => /opt/occlink/Linux/lib/libTKSTEP209-6.5.0.so (0x00007ffd8a72c000)
    libXdmcp.so.6 => /usr/lib/x86_64-linux-gnu/libXdmcp.so.6 (0x00007ffd8a525000)
    libicudata.so.44 => /opt/occlink/Linux/lib/libicudata.so.44 (0x00007ffd894e4000)

So libSketcher.so is not included in the list. Although during build, the option "-lSketcher" appeared in the command line. Strange.
TagsNo tags attached.

Activities

Jriegel

2011-11-27 18:12

administrator   ~0001360

I think you have a somehow messed build environment here...

_emptyValueList was recently implemented in the 0.12 unstabel trunk.

If you really build 0.11 release branch it must not show up...

please do a clean checkout and try again....

wmayer

2011-11-28 13:50

administrator   ~0001369

Check-out latest SVN. Maybe rev 5196 solved this problem.

cfdfriend

2011-11-28 20:14

reporter   ~0001371

I did a fresh checkout of rev 5199 and recompiled everything. On startup it says "FreeCAD 0.12, Libs: 0.12R5199".

But the problem still persists: libSketcherGui.so.2: undefined symbol: _ZN8Sketcher22PropertyConstraintList15_emptyValueListE

cfdfriend

2011-11-28 20:45

reporter   ~0001372

I have now manually copied the library files *.so* from Mod/Sketcher/App/.libs and Mod/Sketcher/Gui/.libs into PREFIX/Mod/Sketcher. Then it works.
It seems that the libraries are linked again during "make install" and the parameters and the result is somehow different during this stage.

wmayer

2011-11-29 09:19

administrator   ~0001374

Question: Did you build with cmake or automake? For cmake a make install isn't required but it is for automake?
If that's not the issue then start FreeCAD with the option "-l" and look at $HOME/.FreeCAD/FreeCAD.log. In the recent past we had some problems on ubuntu 11.10 but I think this should be fixed with R5196.

wmayer

2012-03-01 09:01

administrator   ~0001695

That was an error with in SVN 5196. The problem was that the locally built package was linking a library of an (older and thus binary incompatible) installed FreeCAD version.

Issue History

Date Modified Username Field Change
2011-11-27 10:01 cfdfriend New Issue
2011-11-27 18:12 Jriegel Note Added: 0001360
2011-11-28 13:50 wmayer Note Added: 0001369
2011-11-28 20:14 cfdfriend Note Added: 0001371
2011-11-28 20:45 cfdfriend Note Added: 0001372
2011-11-29 09:19 wmayer Note Added: 0001374
2012-03-01 09:01 wmayer Note Added: 0001695
2012-03-01 09:01 wmayer Status new => closed
2012-03-01 09:01 wmayer Resolution open => fixed
2012-03-01 09:01 wmayer Fixed in Version => 0.13