View Issue Details

IDProjectCategoryView StatusLast Update
0000479FreeCADBugpublic2011-12-10 11:15
ReporterwmayerAssigned ToJriegel 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version0.13 
Summary0000479: Pad: negative value is not allowed
DescriptionThere is an inconsistency in the TaskDlgPadParameters class. The input widget allows to set negative values but when pressing OK an error occurs that negative values are not permitted.

Then there is also a bug in App::PropertyLength. It's derived from PropertyFloat and thus the setValue() method accepts negative values while setPyObject() doesn't. So, it's probably better to inherit from PropertyFloatConstraint and disallow negative values also from C++ side.
TagsNo tags attached.

Activities

wmayer

2011-12-10 11:15

administrator   ~0001437

Pad feature checks for Length and throws an exception if needed. Pad task panel uses a minimum value of zero and checks the status of the pad. If it is invalid it thrown an exception.

PropertyLength hasn't changed because this will be changed once the unit framework is implemented.

Done in rev 5249

Issue History

Date Modified Username Field Change
2011-11-10 17:47 wmayer New Issue
2011-11-10 17:47 wmayer Status new => assigned
2011-11-10 17:47 wmayer Assigned To => Jriegel
2011-12-10 11:15 wmayer Note Added: 0001437
2011-12-10 11:15 wmayer Status assigned => closed
2011-12-10 11:15 wmayer Resolution open => fixed
2011-12-10 11:15 wmayer Fixed in Version => 0.13