View Issue Details

IDProjectCategoryView StatusLast Update
0000473FreeCADBugpublic2011-11-05 13:28
ReportersliptonicAssigned Toyorik 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version0.12 
Summary0000473: Draft preferences for tolerance are not applied or saved correctly.
DescriptionAfter a clean installation of Freecad, importing a dxf with an exploded spline gives bad results (http://img7.imagebanana.com/img/4ha01kl3/Selection_004.png).

Changing the internal precision value in the "Draft Preferences" panel from 3 to 32 and applying it does not fix the problem immediately. However, If Freecad is closed and reopened, the problem is resolved.

Changing the setting back to '3' and applying the change does not reintroduce the problem, even if Freecad is restarted.

Deleting the .FreeCAD directory in the users home directory and allowing FreeCAD to recreate it, reintroduces the problem.
Additional InformationThis is a fairly minor bug, but is likely to affect new users and will be difficult to troubleshoot.

The default value of '3' is probably too low for internal precision for many users. Consider setting the default value higher.
TagsNo tags attached.

Activities

yorik

2011-11-05 13:28

administrator   ~0001253

Last edited: 2011-11-05 13:28

Fixed in r5092
I made 2 changes which should solve the issue:
- Default internal precision value set to 6 instead of 3 (6 decimal places should be enough I suppose?)
- Precision value in DXF import is now polled everytime it is needed, instead of at module import, so no more restart is required

Don't hesitate to reopen if this is still an issue.

Issue History

Date Modified Username Field Change
2011-11-04 17:05 sliptonic New Issue
2011-11-04 17:16 yorik Status new => assigned
2011-11-04 17:16 yorik Assigned To => yorik
2011-11-05 13:28 yorik Note Added: 0001253
2011-11-05 13:28 yorik Status assigned => closed
2011-11-05 13:28 yorik Resolution open => fixed
2011-11-05 13:28 yorik Fixed in Version => 0.12
2011-11-05 13:28 yorik Note Edited: 0001253