View Issue Details

IDProjectCategoryView StatusLast Update
0000472FreeCADBugpublic2011-11-04 18:16
ReporterunauthenticatedAssigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version0.12 
Summary0000472: Arch Icons
DescriptionWindows XP SP3.
ATI Graphics Card

The display of icons in the Arch module is not correct.

See Attached capture.

Nicolas

(Sous Windows XP SP3.
Carte Graphique ATI

L'affichage des icones dans l'atelier Arch ne se fait pas correctement.

Voir la capture Ci-joint.

Nicolas)
TagsNo tags attached.

Activities

2011-11-04 09:24

 

01.png (Attachment missing)

wmayer

2011-11-04 17:56

administrator   ~0001229

Qt's SVG module has some problems in older versions because it only supports SVG Tiny. In newer versions it seems that it has better support but is probably still not perfect.

Two solutions:
1. create a PNG from every SVG file and use this
2. use QtWebkit to render better icons from a SVG

Today I have implemented (but not activated yet) solution 2). So far this works great.

wmayer

2011-11-04 18:16

administrator   ~0001231

Fixed in rev 5090. Using Webkit to render SVG is now activated on Windows.

Issue History

Date Modified Username Field Change
2011-11-04 09:24 unauthenticated New Issue
2011-11-04 09:24 unauthenticated File Added: 01.png
2011-11-04 17:56 wmayer Note Added: 0001229
2011-11-04 18:16 wmayer Note Added: 0001231
2011-11-04 18:16 wmayer Status new => closed
2011-11-04 18:16 wmayer Resolution open => fixed
2011-11-04 18:16 wmayer Fixed in Version => 0.12