View Issue Details

IDProjectCategoryView StatusLast Update
0000459FreeCADFeaturepublic2016-08-14 19:47
ReportermyierAssigned To 
PrioritynormalSeveritytweakReproducibilityalways
Status closedResolutionfixed 
Product Version0.11 
Target VersionFixed in Version0.14 
Summary0000459: Revolving a single line sketch fails
DescriptionA sketch containing a line fails to be revolved, with error: "Creating a face from sketch failed".

A sketch containing an arc can be revolved, a sketch containing two lines can be revolved if they are not collinear.
TagsNo tags attached.

Activities

wmayer

2011-10-31 09:24

administrator   ~0001199

In Part design all operations must return a single solid object. So, it's correct to not revolve single lines. The actual bug is to allow to rotate an arc.

tilas

2011-11-01 11:37

reporter   ~0001204

Last edited: 2011-11-01 11:38

If arc's end-points lye on the rotation axis - it should be valid for revolve operation. Otherwise not.

myier

2011-11-02 09:55

reporter   ~0001214

If I understand correctly, the sketcher should not be used to create objects like a pipe or a toroid with a sketched cross-section? What to use then, constraints are useful for all kinds of objects, not only objects that have a link with their rotation axis.

tilas

2011-11-02 17:47

reporter   ~0001216

I afraid you got it wrong. You can create pipe or thoroid shape IF the profile is closed. For a revolve operation the profile can remain open only IF the axis of rotation is co-linear with the line(s), needed to close it.
Example: if you revolve an arc that of 180 degrees a full turn about the line connecting its end-points, you get a sphere. That's a valid solid.
A pipe can be done in two ways:
In a single step by creating a sketch consisting of two concentric circles and extruding/rotating it or
In two steps by first extruding/revolving a single circle and then extracting/revolving a pocket from it.
I any case the walls of your shape must have a thickness>0 when you work in 'part design'. You can not create 3D surface there. Hopefully in another workbench some day.

Hope it helps

myier

2011-11-02 18:11

reporter   ~0001217

Alright tilas, I understand now. Thank you. I didn't get the thickness issue, now that's clear. I was in fact creating plain objects, when I thought I just had the outer faces and I thought I had display problems due to transparency. The sketcher is even greater than I thought!

Jriegel

2011-11-04 20:57

administrator   ~0001240

Auto close a open profile is a non trivial operation. So at the moment the save bet is to allow only profiles with defined closed wires.

But I leave it as a a feature...

wmayer

2013-07-10 11:27

administrator   ~0003373

git show bebd37a checks if a valid face from the sketch can be created.

normandc

2016-08-07 16:55

manager   ~0007255

Shouldn't this bug be closed then?

Issue History

Date Modified Username Field Change
2011-10-29 22:29 myier New Issue
2011-10-31 09:24 wmayer Note Added: 0001199
2011-11-01 11:37 tilas Note Added: 0001204
2011-11-01 11:38 tilas Note Edited: 0001204
2011-11-02 09:55 myier Note Added: 0001214
2011-11-02 17:47 tilas Note Added: 0001216
2011-11-02 18:11 myier Note Added: 0001217
2011-11-04 20:57 Jriegel Note Added: 0001240
2011-11-04 20:57 Jriegel Status new => acknowledged
2011-11-04 20:57 Jriegel Category Bug => Feature
2013-07-10 11:27 wmayer Note Added: 0003373
2016-08-07 16:55 normandc Note Added: 0007255
2016-08-14 19:47 wmayer Status acknowledged => closed
2016-08-14 19:47 wmayer Resolution open => fixed
2016-08-14 19:47 wmayer Fixed in Version => 0.14