View Issue Details

IDProjectCategoryView StatusLast Update
0000439FreeCADBugpublic2012-01-12 21:38
ReporterpperisinAssigned Towmayer 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version0.13 
Summary0000439: Improve STEP import to find colors attached to sub-shapes
Descriptionhttps://sourceforge.net/apps/phpbb/free-cad/posting.php?mode=reply&f=10&sid=24d1c0dad9aa512964273c81e6364d15&t=1218
TagsNo tags attached.

Activities

miloskomarcevic

2011-11-21 15:42

reporter   ~0001340

Last edited: 2011-11-21 16:12

I'm also seeing a STEP color import issue and found some strange results on 0.12 r5150.

If the assembly in the STEP is flat (most files I came acorss), all color information is lost.

If there are subassemblies present however, the ones on the second level get their color imported correctly, while parts on the first level get their color dropped.

Example is attached, which imports in CAD Exchanger just fine (blue lenses in top assembly level).

Note: Don't be fooled by this model being AP203. It's "AP203 with extensions" [1,2]. The result is still the same when you reexport it as AP214 from CAD Exchanger.

[1] http://www.cax-if.org/documents/RecPrac_Cols_Lays_A4_2.pdf
[2] http://www.cax-if.org/documents/ccd_cla_gvp_ast_asd.exp

2011-11-21 15:42

 

Winnie.zip (Attachment missing)

wmayer

2012-01-11 15:14

administrator   ~0001561

With http://free-cad.svn.sourceforge.net/viewvc/free-cad?view=revision&revision=5396 the import has improved quite a lot. However, I still have another two files which doesn't fully work. And for one of these files there is even a regression.

However, the attached STEP file loads perfectly now.

pperisin

2012-01-11 17:25

reporter   ~0001562

thank you very much, werner, for looking into this.

wmayer

2012-01-11 20:10

administrator   ~0001563

Last edited: 2012-01-11 20:13

OK, in rev 5399 the above mentioned file with the regression works perfectly too. The only failing file I have is the seatmotor2.igs file shipped with CAD Exchanger.

Edit: The improved import function is available in the Part module under "Shape". The normal open/import function from the File menu still fails in many cases. Here I plan to ignore again the colors and names.

pperisin

2012-01-11 21:29

reporter   ~0001564

Werner,

I can not test now since I need to wait for ppa to update,

can you tell me does this one work ok?

http://dl.dropbox.com/u/36707971/DT01.7z

Regards,
Petar

wmayer

2012-01-11 23:54

administrator   ~0001565

I'm currently under Linux where I don't have CADExchanger and thus cannot compare but the result looks really good.

wmayer

2012-01-12 08:35

administrator   ~0001566

OK back on Windows. I see no difference of the display of the DT01 file between FreeCAD or CAD Exchanger.

pperisin

2012-01-12 14:47

reporter   ~0001569

Hi,

I just got ppa update - 5034 launchpad. released today. I see no difference. Maybe it will be in tomorrow's update.

also, you say it is under "Shape", in Part module. Do you mean under "Part" in part module.

Regards
Petar

wmayer

2012-01-12 21:38

administrator   ~0001570

Oh sorry, it's indeed Part.

For the seatmotor2.igs I used OCC's OCAF browser and I think FreeCAD loads this file correctly. The file only defines two colors the one referenced by 19 faces and 6 wires and the other color by two wires. That's exactly what FreeCAD does.

I don't know why CAD Exchanger shows something different, maybe an error there or it sets some special mode so that the IGES import leads to a different XDE document.

Nevertheless, I think this bug can be regarded as fixed.

Issue History

Date Modified Username Field Change
2011-09-22 06:14 wmayer New Issue
2011-09-22 06:14 wmayer Status new => assigned
2011-09-22 06:14 wmayer Assigned To => wmayer
2011-09-22 06:15 wmayer Reporter wmayer => pperisin
2011-11-21 15:42 miloskomarcevic Note Added: 0001340
2011-11-21 15:42 miloskomarcevic File Added: Winnie.zip
2011-11-21 15:43 miloskomarcevic Note Edited: 0001340
2011-11-21 16:12 miloskomarcevic Note Edited: 0001340
2012-01-11 15:14 wmayer Note Added: 0001561
2012-01-11 17:25 pperisin Note Added: 0001562
2012-01-11 20:10 wmayer Note Added: 0001563
2012-01-11 20:13 wmayer Note Edited: 0001563
2012-01-11 21:29 pperisin Note Added: 0001564
2012-01-11 23:54 wmayer Note Added: 0001565
2012-01-12 08:35 wmayer Note Added: 0001566
2012-01-12 14:47 pperisin Note Added: 0001569
2012-01-12 21:38 wmayer Note Added: 0001570
2012-01-12 21:38 wmayer Status assigned => closed
2012-01-12 21:38 wmayer Resolution open => fixed
2012-01-12 21:38 wmayer Fixed in Version => 0.13