View Issue Details

IDProjectCategoryView StatusLast Update
0000438FreeCADBugpublic2011-09-19 05:17
ReporterJriegelAssigned Towmayer 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target Version0.12Fixed in Version0.12 
Summary0000438: Subselection don't work on PythonFeature objects
DescriptionAs reported by yorik:

https://sourceforge.net/apps/phpbb/free-cad/viewtopic.php?f=10&t=1328&p=10186#p10186
TagsNo tags attached.

Activities

Jriegel

2011-09-16 03:57

administrator   ~0001073

Should no big deal (I think). I would like Werner to do it
since he made the Python features and the new slection.

yorik

2011-09-16 23:55

administrator   ~0001098

I just recopy here the text from the linked thread so there is no need to go read there:

I just notice that python features (Part::FeaturePython and Part::Part2DObjectPython) are missing the subcomponent name (Edge1, Face14, etc...) when you use Selection.GetSelectionEx() or even in the status bar when you hover the mouse over them...

wmayer

2011-09-19 05:17

administrator   ~0001125

Fixed in r4943

Issue History

Date Modified Username Field Change
2011-09-16 03:56 Jriegel New Issue
2011-09-16 03:56 Jriegel Status new => assigned
2011-09-16 03:56 Jriegel Assigned To => wmayer
2011-09-16 03:57 Jriegel Note Added: 0001073
2011-09-16 05:06 Jriegel Product Version trunk =>
2011-09-16 05:06 Jriegel Target Version => 0.12
2011-09-16 23:55 yorik Note Added: 0001098
2011-09-19 05:17 wmayer Note Added: 0001125
2011-09-19 05:17 wmayer Status assigned => closed
2011-09-19 05:17 wmayer Resolution open => fixed
2011-09-19 05:17 wmayer Fixed in Version => 0.12