View Issue Details

IDProjectCategoryView StatusLast Update
0000435FreeCADBugpublic2011-09-16 04:02
ReporternormandcAssigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Versiontrunk 
Target VersionFixed in Version0.12 
Summary0000435: Sketcher: Auto constrains add one coincident constraint too many to a closed polyline
DescriptionIn Sketcher while creating a closed polyline with Auto constraints active, the last point that closes the polyline (where the first line segment and the last connect) gets two coincident constraints.

Steps to reproduce: in the Sketcher,

1 - Start a new Sketch
2 - Select the polyline tool
3 - Create a closed polygon
4 - In TaskView, set the Constraint filter to "All"

There is one more coincident constraint than there are vertexes.

Deselecting the auto constraints prior to closing the polyline creates the right number of coincident constraints.

This duplicated constraint causes the Fillet tool to not be able to click on the vertex that closed the polygon, the cursor with Fillet icon is replaced with a "forbidden" icon (white circle with a diagonal line in it). Deleting the duplicated constraint works around the problem (or selecting the lines segments instead does too)
Additional InformationFreeCAD v0.12-bzr4552 on Ubuntu 10.04 LTS 64-Bit
TagsNo tags attached.

Activities

normandc

2011-09-11 20:09

manager   ~0001062

It looks like logari81 fixed this a few hours before I posted the bug.

See http://free-cad.svn.sourceforge.net/viewvc/free-cad?view=revision&revision=4909

logari81

2011-09-12 07:55

developer   ~0001063

yes I fixed that but I think that I have introduced another bug. Now we have no autoconstraints at all in the last line segment, not even horizontal or vertical.

I will correct it later.

logari81

2011-09-12 20:16

developer   ~0001064

now it should be fixed correctly.
http://free-cad.svn.sourceforge.net/viewvc/free-cad?view=revision&revision=4918

Jriegel

2011-09-16 04:02

administrator   ~0001075

fixed 4918

Issue History

Date Modified Username Field Change
2011-09-11 18:40 normandc New Issue
2011-09-11 20:09 normandc Note Added: 0001062
2011-09-12 07:55 logari81 Note Added: 0001063
2011-09-12 20:16 logari81 Note Added: 0001064
2011-09-16 04:02 Jriegel Note Added: 0001075
2011-09-16 04:02 Jriegel Status new => closed
2011-09-16 04:02 Jriegel Resolution open => fixed
2011-09-16 04:02 Jriegel Fixed in Version => 0.12