View Issue Details

IDProjectCategoryView StatusLast Update
0000426FreeCADBugpublic2011-09-17 06:26
ReportermrlukeparryAssigned ToJriegel 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Versiontrunk 
Target VersionFixed in Version0.12 
Summary0000426: Sketcher:: Create polyline, perform Undo whilst adding lineSegment or wire and then adding another wire crashes
DescriptionCreate a polyline add a linesSegments or wires and then undo one line. The drawsketcher line is incorrectly placed and adding the line causes assert error because curve geometry is not updated.

I guess that DrawSketchHandlerLineSet::previousCurve value is incorrect and not updated when the undo transaction is performed
TagsNo tags attached.

Activities

wmayer

2011-08-26 14:46

administrator   ~0001008

Does this still happen? I ask this because you made some changes in the command classes today and I can't reproduce this.

Jriegel

2011-09-16 04:50

administrator   ~0001089

Works now. Not perfect but works...

wmayer

2011-09-17 06:26

administrator   ~0001102

Set to closed.

Issue History

Date Modified Username Field Change
2011-08-26 08:26 mrlukeparry New Issue
2011-08-26 14:46 wmayer Note Added: 0001008
2011-08-27 06:00 Jriegel Status new => assigned
2011-08-27 06:00 Jriegel Assigned To => Jriegel
2011-09-16 04:50 Jriegel Note Added: 0001089
2011-09-16 04:50 Jriegel Status assigned => resolved
2011-09-16 04:50 Jriegel Fixed in Version => 0.12
2011-09-16 04:50 Jriegel Resolution open => fixed
2011-09-17 06:26 wmayer Note Added: 0001102
2011-09-17 06:26 wmayer Status resolved => closed