View Issue Details

IDProjectCategoryView StatusLast Update
0000425FreeCADBugpublic2011-12-25 14:20
Reportergalou_breizhAssigned Tologari81 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version0.13 
Summary0000425: Sketcher: line-on-point constraint freeze
DescriptionFreeCAD freezes when moving a line to which a point is constrained with point-on-line constraint.
Additional Informationlatest Ubuntu PPA
TagsNo tags attached.

Activities

mrlukeparry

2011-08-26 08:17

developer   ~0001004

Could you provide more information please. Can you give the exact steps to reproduce this crash?

Also are there any error messages?

galou_breizh

2011-08-26 09:34

reporter   ~0001005

- Create a new sketch
- create a line
- create a second line
- select one point of the second line and the first line
- add constraint "Fix a point onto an object
- move the line --> freeze (no error message)

also freezes when:
- moving the constrained point
- the constrained point is on the line but not on the segment, i.e. not between the two points of the first line

galou_breizh

2011-08-26 09:34

reporter   ~0001006

CPU = 100% when frozen

wmayer

2011-08-26 14:40

administrator   ~0001007

With the latest SVN revision I can't reproduce this. But I know we had similar cases in the recent past. So, good possible that this is fixed now. Just wait for the next PPA version and re-check.

wmayer

2011-08-27 08:31

administrator   ~0001011

Yesterday night I tested the PPA version where I could see the freeze but the latest SVN build seems to fix it.

galou_breizh

2011-08-29 05:27

reporter   ~0001014

Launchpad 4471 (2011-08-29) still has the problem but in some cases there is no freeze:
- move the line by clicking somewhere between its two endpoints (reproducible)
- moving the constrained point (sometimes freecad freezes sometimes it doesn't).

wmayer

2011-08-30 13:41

administrator   ~0001017

The problem could be in: int System::solve(SubSystem *subsysA, SubSystem *subsysB, int isFine)
Having a similar case the for loop iterates until it reaches maxIterNumber but then by a little movement System::solve is called again.

logari81

2011-08-30 14:01

developer   ~0001018

sorry I couldn't reproduce it on my system so far.

wmayer

2011-11-05 23:09

administrator   ~0001261

I have the feeling that this freeze only happens with the PPA version but not we locally compiled versions. Also a locally built debian package works nice.

So, there might be something weird with the PPA package.

galou_breizh

2011-12-19 08:54

reporter   ~0001491

Last edited: 2011-12-19 08:54

Solved in PPA version 4963 (Launchpad).

Issue History

Date Modified Username Field Change
2011-08-26 07:38 galou_breizh New Issue
2011-08-26 08:17 mrlukeparry Note Added: 0001004
2011-08-26 09:34 galou_breizh Note Added: 0001005
2011-08-26 09:34 galou_breizh Note Added: 0001006
2011-08-26 14:40 wmayer Note Added: 0001007
2011-08-27 08:31 wmayer Note Added: 0001011
2011-08-29 05:27 galou_breizh Note Added: 0001014
2011-08-30 13:41 wmayer Note Added: 0001017
2011-08-30 13:42 wmayer Status new => assigned
2011-08-30 13:42 wmayer Assigned To => logari81
2011-08-30 14:01 logari81 Note Added: 0001018
2011-11-03 17:29 logari81 Product Version trunk =>
2011-11-03 17:29 logari81 Summary line-on-point constraint freeze => Sketcher: line-on-point constraint freeze
2011-11-05 23:09 wmayer Note Added: 0001261
2011-12-19 08:54 galou_breizh Note Added: 0001491
2011-12-19 08:54 galou_breizh Note Edited: 0001491
2011-12-19 09:41 logari81 Status assigned => closed
2011-12-19 09:41 logari81 Resolution open => fixed
2011-12-19 09:41 logari81 Fixed in Version => trunk
2011-12-25 14:20 yorik Fixed in Version trunk => 0.13