View Issue Details

IDProjectCategoryView StatusLast Update
0000422FreeCADBugpublic2011-09-28 20:31
ReporterpperisinAssigned ToJriegel 
PrioritynormalSeveritytrivialReproducibilityalways
Status closedResolutionfixed 
Product Version 
Target VersionFixed in Version0.12 
Summary0000422: Sketcher inverts horizontal and vertical constraints in YZ plane
DescriptionHi,

Sketcher inverts horizontal and vertical constraints in YZ plane

Regards
Petar
Additional InformationCreate box
select one of it's YZ sides
Create new sketch
place line
select line
add horizontal constraint to it
TagsNo tags attached.

Activities

2011-08-23 12:50

 

sketch.FCStd (Attachment missing)

pperisin

2011-08-23 12:52

reporter   ~0000992

It is also issue with "Fix horizontal distance" and "fix vertical distance"

look at the file - although in sketch this shape is on the left side of z axis, when you close it one part of it crosses z axis.

pperisin

2011-08-23 13:10

reporter   ~0000993

also, couple of more issues with this file

create a pad from this file and the open sketch for editing again. you will see where the pad is and where the sketch is

Regards
Petar

Jriegel

2011-08-24 13:44

administrator   ~0000995

I think this is not about the constraints, its about the calculating of the
sketch base system....

mrlukeparry

2011-09-08 17:22

developer   ~0001052

Yeah. The axis are incorrectly orientated. You'll notice that the constraints are correct relative to coordinates.

its may be nice to look at fixing when we get reference geometries

Jriegel

2011-09-16 04:04

administrator   ~0001076

Its only a problem of view direction, if you rotate the view 90 deg alls fine!

Jriegel

2011-09-16 04:05

administrator   ~0001077

Not a bug, maybe a inconvenience with the standard view directions.

wmayer

2011-09-17 06:27

administrator   ~0001103

Set to closed.

wmayer

2011-09-26 15:02

administrator   ~0001133

http://forum.freecadweb.org/viewtopic.php?f=10&t=1393#p10546 shows the steps how to reproduce it

wmayer

2011-09-28 20:31

administrator   ~0001136

Fixed with r4979

Issue History

Date Modified Username Field Change
2011-08-23 12:25 pperisin New Issue
2011-08-23 12:50 pperisin File Added: sketch.FCStd
2011-08-23 12:52 pperisin Note Added: 0000992
2011-08-23 13:10 pperisin Note Added: 0000993
2011-08-24 13:44 Jriegel Note Added: 0000995
2011-09-08 17:22 mrlukeparry Note Added: 0001052
2011-09-16 04:04 Jriegel Note Added: 0001076
2011-09-16 04:05 Jriegel Note Added: 0001077
2011-09-16 04:05 Jriegel Status new => resolved
2011-09-16 04:05 Jriegel Resolution open => fixed
2011-09-16 04:05 Jriegel Assigned To => Jriegel
2011-09-16 04:06 Jriegel Resolution fixed => no change required
2011-09-17 06:27 wmayer Note Added: 0001103
2011-09-17 06:27 wmayer Status resolved => closed
2011-09-26 15:02 wmayer Note Added: 0001133
2011-09-26 15:02 wmayer Status closed => confirmed
2011-09-26 15:02 wmayer Resolution no change required => reopened
2011-09-26 15:02 wmayer Product Version trunk =>
2011-09-28 20:31 wmayer Note Added: 0001136
2011-09-28 20:31 wmayer Status confirmed => closed
2011-09-28 20:31 wmayer Resolution reopened => fixed
2011-09-28 20:31 wmayer Fixed in Version => 0.12