View Issue Details

IDProjectCategoryView StatusLast Update
0000417FreeCADBugpublic2011-08-17 14:26
ReporterunauthenticatedAssigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Versiontrunk 
Target VersionFixed in Version0.12 
Summary0000417: FreeCad does not compile with eigen 3.0.1
DescriptionTrying to compile the latest trunk version (4766) I got this error:


In file included from kdl_cp/utilities/svd_eigen_HH.cpp:22:0:
kdl_cp/utilities/svd_eigen_HH.hpp:31:1: error: 'USING_PART_OF_NAMESPACE_EIGEN' does not name a type

That's because USING_PART_OF_NAMESPACE_EIGEN has been removed. The necessary files have to be #included.
TagsNo tags attached.

Activities

wmayer

2011-08-17 08:37

administrator   ~0000979

What is your platform? Actually there is a special define in Eigen3 "EIGEN2_SUPPORT" which allows to replace Eigen2 without changing a single line.

unauthenticated

2011-08-17 10:45

viewer   ~0000981

I use the Arch freecad-svn package from AUR (with the according eigen3 package). Seems like the eigen3 conflicts somehow with the eigen2 package (which is required by kde since 4.7). Removing eigen3 and using eigen2 gives another error, but this one does not seem to be eigen2/3 related (?):

sed: kann /home/goethel/build/freecad-svn/pkg/usr/lib/freecad-svn/Mod/Robot/MovieTool.py nicht lesen: Datei oder Verzeichnis nicht gefunden

unauthenticated

2011-08-17 11:39

viewer   ~0000982

It works with 4767 an eigen2/3 both installed.

wmayer

2011-08-17 14:26

administrator   ~0000984

The EIGEN2_SUPPORT define was missing. Fixed in r4767.

Issue History

Date Modified Username Field Change
2011-08-17 06:27 unauthenticated New Issue
2011-08-17 08:37 wmayer Note Added: 0000979
2011-08-17 10:45 unauthenticated Note Added: 0000981
2011-08-17 11:39 unauthenticated Note Added: 0000982
2011-08-17 14:26 wmayer Note Added: 0000984
2011-08-17 14:26 wmayer Status new => closed
2011-08-17 14:26 wmayer Resolution open => fixed
2011-08-17 14:26 wmayer Fixed in Version => 0.12