View Issue Details

IDProjectCategoryView StatusLast Update
0000376FreeCADFeaturepublic2011-06-15 14:08
ReporterunauthenticatedAssigned To 
PrioritynormalSeveritymajorReproducibilityN/A
Status closedResolutionfixed 
Product Version0.11 
Target VersionFixed in Version0.12 
Summary0000376: Additional 3D navigation modes
DescriptionFor me (On mac OS X) the two available 3D navigation modes really don't work, and as it's such a central feature it's a big problem.

In "CAD navigation" mode I can select objects, but I can't rotate since pressing the middle button and left button at the same time doesn't work and instead scrolls (as the middle button is the scroll wheel).

In "Inventor navigation" mode I can rotate fine, but I can't select anything, since control-clicking brings up the right click context menu.

So I have to switch between the two constantly. Please add a third navigation mode, (almost consistent with Blender, another open source 3D project)
*Blender mode*
Selection: Left mouse button
Rotation: Middle mouse button
Panning: Shift+Middle mouse button
Zooming: Scroll wheel
TagsNo tags attached.

Activities

wmayer

2011-06-14 10:22

administrator   ~0000896

I assume you know that the navigation mode can be quickly changed in the context-menu.

For CAD navigation there is an alternative way for rotating. Press SHIFT + right mouse button.

Jriegel

2011-06-14 12:43

administrator   ~0000898

Is it actually not possible on Mac or are you not able to? Mean do OsX not handle all three mouse buttons independently?

The mouse model is the Catia V5 mouse model. As a CAD program its more
the standard then e.g. blender which is CGI.

wmayer

2011-06-15 14:08

administrator   ~0000903

Implemented in r4575

Issue History

Date Modified Username Field Change
2011-06-14 08:55 unauthenticated New Issue
2011-06-14 10:22 wmayer Note Added: 0000896
2011-06-14 12:43 Jriegel Note Added: 0000898
2011-06-15 14:08 wmayer Note Added: 0000903
2011-06-15 14:08 wmayer Status new => closed
2011-06-15 14:08 wmayer Resolution open => fixed
2011-06-15 14:08 wmayer Fixed in Version => 0.12