View Issue Details

IDProjectCategoryView StatusLast Update
0000375FreeCADBugpublic2011-09-17 08:16
ReporterunauthenticatedAssigned Towmayer 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.11 
Target VersionFixed in Version0.12 
Summary0000375: Mac Interface window style setting not saved
DescriptionOn the mac build the interface window style setting isn't saved between launches. Instead it reverts to the Aqua theme every time it's launched.
TagsNo tags attached.

Activities

yorik

2011-06-14 18:05

administrator   ~0000902

It happens for me too on linux (what I specify there is not saved). But I see this preference setting calls directly a Qt mechanism (the setting is saved in one of the Qt config files, not in freecad user.cfg) but that mechanism is appearently not used. But Qt has many styling problems when running without kde...

Anyway I wonder if this is a really useful setting to have? Shouldn't the user configure his Qt styling/theming outside freecad?

wmayer

2011-06-15 14:28

administrator   ~0000904

In a previous version we stored this setting into the user.cfg file and loaded it at startup. However, there was a certain reason not to do that anymore. Unfortunately I cannot remember this reason.

But FreeCAD can be started with the parameter -style, e.g. FreeCAD -style=CDE

Maybe Yorik is right and we should remove this style stuff from the preferences.

normandc

2011-06-24 13:56

manager   ~0000908

I confirm this behavior on Ubuntu 10.04 LTS too.

I have many KDE packages installed since I use some KDE apps. I control their appearance with systemsettings GUI, but FreeCAD does not seem to be affected.

There is a GUI interface to configure the look and behavior of Qt apps, the package is qt4-qtconfig (Qt4 Configuration Tool) in Ubuntu. maybe it's available on MacOS X as well.

But truth is, Qt apps on my system adjust to my GNOME/Gtk preferences automatically, and it's just the way I like it.

yorik

2011-06-24 14:10

administrator   ~0000909

If I use KDE systemsettings, FreeCAD reacts correctly (pretty cool with qtCurve ;) . Once I remember I had to delete a kde config file in ~/.config that contained FreeCAD settings, that would prevent it from taking system-wide KDE preferences, but that was long time ago.

But Normand, on your ubuntu, freecad also follow the gtk theme, just like other qt apps, right?

Jriegel

2011-09-16 04:39

administrator   ~0001084

Im not quit sure on that, do we have a problem here?! Close it if you want....

normandc

2011-09-16 19:14

manager   ~0001095

Oops, I never answered Yorik's question. Yes, on both Ubuntu 10.04 and 11.04, FreeCAD follows the GTK theme.

yorik

2011-09-16 19:44

administrator   ~0001096

Then it works like expected, IMHO. I would vote to remove the style setting from the preferences...

wmayer

2011-09-17 08:16

administrator   ~0001112

Fixed in r4935. The window style combo box is now hidden.

Issue History

Date Modified Username Field Change
2011-06-14 08:44 unauthenticated New Issue
2011-06-14 18:05 yorik Note Added: 0000902
2011-06-15 14:28 wmayer Note Added: 0000904
2011-06-24 13:56 normandc Note Added: 0000908
2011-06-24 14:10 yorik Note Added: 0000909
2011-09-16 04:39 Jriegel Status new => assigned
2011-09-16 04:39 Jriegel Assigned To => wmayer
2011-09-16 04:39 Jriegel Note Added: 0001084
2011-09-16 19:14 normandc Note Added: 0001095
2011-09-16 19:44 yorik Note Added: 0001096
2011-09-17 08:16 wmayer Note Added: 0001112
2011-09-17 08:16 wmayer Status assigned => closed
2011-09-17 08:16 wmayer Resolution open => fixed
2011-09-17 08:16 wmayer Fixed in Version => 0.12