View Issue Details

IDProjectCategoryView StatusLast Update
0003737FreeCAD[All Projects] Generalpublic2018-12-19 09:24
ReporterterrysbestfriendAssigned To 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionno change required 
Product Version0.19 
Target VersionFixed in Version 
Summary0003737: neue Installation startet nicht
DescriptionGuten Tag,
habe gerade FreeCAD auf einer Linux Maschine unter KUbuntu 18.04.LTS aus dem pps über die Konsole installiert.
(sudo add-apt-repository ppa:freecad-maintainers/freecad-stable) und
(sudo apt-get install freecad freecad-doc && sudo apt-get upgrade)
Nach Aufruf (freecad) erscheint folgendes:
FreeCAD 0.17, Libs: 0.17R13541 (Git)
© Juergen Riegel, Werner Mayer, Yorik van Havre 2001-2018
  ##### #### ### ####
  # # # # # #
  # ## #### #### # # # # #
  #### # # # # # # # ##### # #
  # # #### #### # # # # #
  # # # # # # # # # ## ## ##
  # # #### #### ### # # #### ## ## ##

failed to create drawable
[xcb] Unknown sequence number while processing queue
[xcb] Most likely this is a multi-threaded client and XInitThreads has not been called
[xcb] Aborting, sorry about that.
freecad: ../../src/xcb_io.c:259: poll_for_event: Zusicherung »!xcb_xlib_threads_sequence_lost« nicht erfüllt.
Abgebrochen (Speicherabzug geschrieben)

Mir als Laie sagt das nichts.

Kann mir da jemand helfen ?
TagsNo tags attached.

Relationships

related to 0003717 resolved FreeCAD AppImage fils to start: failed to create drawable 

Activities

Kunda1

2018-12-18 11:39

manager   ~0012299

@terrysbestfriend please read https://freecadweb.org/wiki/Tracker
We ask that you first open a forum thread https://forum.freecadweb.org/viewforum.php?f=13

Also please do not create a bug report in any language but english.

Kunda1

2018-12-18 11:41

manager   ~0012300

Looks related to #3717

wmayer

2018-12-18 13:47

administrator   ~0012302

It's hard to say what exactly causes the problem. Maybe it's related to the graphic driver because when searching for the environment variable LIBGL_DRI3_DISABLE then the mesa project uses it: https://www.mesa3d.org/envvars.html

A workaround to make FreeCAD working again is to set this variable:
export LIBGL_DRI3_DISABLE=true
in a terminal and then start FreeCAD from there. To avoid to do this all the time I recommend to create a FreeCAD.desktop file and set the variable inside there [1].

I do not know if this will be fixed any time soon but what I know for sure is that it's not a FreeCAD bug.

[1] https://askubuntu.com/questions/144968/set-variable-in-desktop-file

Kunda1

2018-12-19 09:23

manager   ~0012309

Last edited: 2018-12-19 09:24

View 2 revisions

Closing ticket

Issue History

Date Modified Username Field Change
2018-12-18 04:21 terrysbestfriend New Issue
2018-12-18 11:39 Kunda1 Note Added: 0012299
2018-12-18 11:41 Kunda1 Relationship added related to 0003717
2018-12-18 11:41 Kunda1 Note Added: 0012300
2018-12-18 13:47 wmayer Note Added: 0012302
2018-12-19 09:23 Kunda1 Status new => closed
2018-12-19 09:23 Kunda1 Resolution open => no change required
2018-12-19 09:23 Kunda1 Note Added: 0012309
2018-12-19 09:24 Kunda1 Note Edited: 0012309 View Revisions