View Issue Details

IDProjectCategoryView StatusLast Update
0003726FreeCADBugpublic2018-12-16 20:41
ReporterwandererfanAssigned Towmayer 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.18 
Target VersionFixed in Version0.18 
Summary0003726: Property Editor Angle Fields Do Not Respect Units
DescriptionGui::PropertyEditor::PropertyAngleItem uses a QDoubleSpinBox with a hard-coded degree symbol.

This means that angles can not be entered in a format suitable for Civil Engineering/Surveying (d°m's" in US and grad/gon in Europe)

PropertyAngleItem should use QuantitySpinBox(?).
Steps To Reproduceset Units to a non-degree schema (currently only ImperialCivil). Add a Part::Sphere to a document. Try to edit the Angle parameters of the Sphere. Only decimal degrees are displayed/enterable.
TagsNo tags attached.

Activities

wmayer

2018-12-16 20:41

administrator   ~0012285

https://github.com/FreeCAD/FreeCAD/commit/766383d411402f6b77438afb01ff3517fd8cf3ab

At the moment the property item still shows the degree symbol when not being edited. This is a bug in your class UnitsSchemaImperialCivil because there it still sets this symbol.
Another bug there is that negative angles are converted into positive values which makes the creation of many standard geometries impossible.

Example: Use the Create primitive dialog of the Part workbench and try to create a sphere. It will fail because lower and upper angle in v space are set to 90 degree instead of -90 and 90.

Issue History

Date Modified Username Field Change
2018-12-12 12:01 wandererfan New Issue
2018-12-16 20:41 wmayer Assigned To => wmayer
2018-12-16 20:41 wmayer Status new => closed
2018-12-16 20:41 wmayer Resolution open => fixed
2018-12-16 20:41 wmayer Fixed in Version => 0.18
2018-12-16 20:41 wmayer Note Added: 0012285