View Issue Details

IDProjectCategoryView StatusLast Update
0003680FreeCADBugpublic2018-11-10 18:03
ReporterwaterlubberAssigned Towmayer 
PrioritylowSeveritytrivialReproducibilityalways
Status closedResolutionfixed 
PlatformLinuxOSLinux MintOS Version18.3
Product Version0.18 
Target VersionFixed in Version0.18 
Summary0003680: Export (Ctrl+E) doesn't check to make sure that object being exported is a model at all
Description[url=https://forum.freecadweb.org/viewtopic.php?p=268100#p268100]Forum Thread
[/url]
When exporting an object, such as a Spreadsheet, with Ctrl+E, the exporter doesn't check that the thing being exported is reasonable. For example, when exporting the aforementioned spreadsheet, no errors are thrown and the exported file is nearly blank. This results in user confusion when they, for example, spend a few minutes wondering why their exported .stl is blank because they were highlighting the wrong thing.

The contents of the aforementioned STL:
[code=hex]
(raw)
4D 45 53 48 2D 4D 45 53 48 2D 4D 45 53 48 2D 4D 45 53 48 2D 4D 45 53 48 2D 4D 45 53 48 2D 4D 45 53 48 2D 4D 45 53 48 2D 4D 45 53 48 2D 4D 45 53 48 2D 4D 45 53 48 2D 4D 45 53 48 2D 4D 45 53 48 2D 4D 45 53 48 2D 4D 45 53 48 2D 4D 45 53 48 0A 00 00 00 00

(text)
MESH-MESH-MESH-MESH-MESH-MESH-MESH-MESH-MESH-MESH-MESH-MESH-MESH-MESH-MESH-MESH[/code]

Attached is the weird stl itself if you want to look at it
Steps To Reproduce[list=1]
[*]Create a new document and a blank spreadsheet
[*]Select the spreadsheet on the "Labels and Attributes" window
[*]Press Ctrl+E to export
[*]Select STL
[*]Watch as a mysteriously small STL is created silently
[/list]
Additional InformationOS: Linux Mint 18.3 Sylvia
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.18.15162 (Git)
Build type: Release
Branch: master
Hash: 1d72ee43435fa099ae97a2f6e3d15a225d4f32d3
Python version: 2.7.12
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: English/UnitedStates (en_US)
TagsNo tags attached.

Activities

waterlubber

2018-11-10 16:59

reporter  

hwat.stl (84 bytes)

wmayer

2018-11-10 18:03

administrator   ~0012168

https://github.com/FreeCAD/FreeCAD/commit/04005b5e452a7b8624f2aeac5180787d4f6a88fa

Issue History

Date Modified Username Field Change
2018-11-10 16:59 waterlubber New Issue
2018-11-10 16:59 waterlubber File Added: hwat.stl
2018-11-10 18:03 wmayer Assigned To => wmayer
2018-11-10 18:03 wmayer Status new => closed
2018-11-10 18:03 wmayer Resolution open => fixed
2018-11-10 18:03 wmayer Fixed in Version => 0.18
2018-11-10 18:03 wmayer Note Added: 0012168