View Issue Details

IDProjectCategoryView StatusLast Update
0003642SketcherBugpublic2018-12-20 12:57
ReporterchrisbAssigned Toabdullah 
PrioritynormalSeveritytweakReproducibilityalways
Status closedResolutionfixed 
Product Version0.18 
Target Version0.18Fixed in Version0.18 
Summary0003642: Deleting a constraint triggers recompute
DescriptionDeleting a constraint in Sketcher triggers always a recompute of the document. This can be very time consuming on larger models, because the recompute takes place on every single constraint. This is independent from the state of the "Auto update" checkbox.
[url=https://forum.freecadweb.org/viewtopic.php?f=3&t=31601]Forum discussion[/url]
TagsNo tags attached.

Activities

abdullah

2018-10-19 16:53

manager   ~0012075

Note to self: Read Werner's post:
https://forum.freecadweb.org/viewtopic.php?p=262973#p263018

abdullah

2018-12-19 15:49

manager   ~0012314

git commit 296471637aaab66f12b1fab4727834a30e3f6d06

abdullah

2018-12-19 15:49

manager   ~0012315

git commit 296471637aaab66f12b1fab4727834a30e3f6d06

Kunda1

2018-12-20 12:57

manager   ~0012327

Edited Target version to 0.18 since this ticket was technically closed before the 0.18 release

Issue History

Date Modified Username Field Change
2018-10-18 13:57 chrisb New Issue
2018-10-18 13:57 chrisb Status new => assigned
2018-10-18 13:57 chrisb Assigned To => abdullah
2018-10-19 16:53 abdullah Note Added: 0012075
2018-12-19 15:49 abdullah Note Added: 0012314
2018-12-19 15:49 abdullah Status assigned => closed
2018-12-19 15:49 abdullah Resolution open => fixed
2018-12-19 15:49 abdullah Fixed in Version => 0.18
2018-12-19 15:49 abdullah Note Added: 0012315
2018-12-20 12:57 Kunda1 Target Version 0.19 => 0.18
2018-12-20 12:57 Kunda1 Note Added: 0012327