View Issue Details

IDProjectCategoryView StatusLast Update
0003623TechDraw[FreeCAD] Bugpublic2018-10-23 11:33
ReporterchapattAssigned Towandererfan 
PrioritynormalSeverityminorReproducibilitysometimes
Status closedResolutionfixed 
Product Version[FreeCAD] 0.17 
Target Version[FreeCAD] 0.18Fixed in Version[FreeCAD] 0.18 
Summary0003623: "Building US" unit system rounding issue (e.g. 1' 12" vs. 2')
DescriptionTechdraw often shows dimensions of a length in even feet, n, as (n-1)' 12" instead of n'. It seems to be random when it does this. See attached screenshot and example file of a sketch and a drawing of it.
Steps To Reproduce[list=1]
[*]In [i]User Preferences[/i], set [i]Units[/i] to [i]Building US[/i].
[*]In the [i]Sketcher[/i] workbench, create a sketch and draw some geometry and constrain parts with dimensions of integer multiples of feet, e.g. 3', 10', etc.
[*]In the [i]TechDraw[/i] workbench, create a new drawing, click the [i]Insert multiple views...[/i] button and create a view for the sketch with a perspective perpendicular to it so it appears as it did when editing the sketch.
[*]Add dimensions to some of the same geometry as you dimensioned in [i]Sketcher[/i]
[/list]
Additional InformationOS: Windows 10
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.17.13541 (Git)
Build Type: Release
Branch: releases/FreeCAD-0-17
Hash: 9948ee4f1570df9216862a79705afb367b2c6ffb
Python version: 2.7.14
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 7.2.0
Locale: English/UnitedStates (en_US)
Tagsunits

Activities

chapatt

2018-10-04 18:18

reporter  

techdraw_dimension_bug.FCStd (12,342 bytes)

chapatt

2018-10-04 18:23

reporter   ~0011923

The example file uses this drawing template.

us-letter_landscape_plain.svg (1,624 bytes)

wandererfan

2018-10-05 12:35

developer   ~0011927

weird. Only some dimensions are affected. This only happens with "use system decimals" true. With "use alt decimals", the dimvalues are all 0.0 and no units appear.

wandererfan

2018-10-05 13:19

developer   ~0011931

This seems to be fixed in v0.18? Same file in 17 shows 10' 12", in 18 shows 11'. Changes in Units subsystem?

There is a problem with ft/in measurements in TD if "use alt decimals" is ticked. Measurements come out as 0 - issue with formatSpec for 1 value, but 2 values in input??

chapatt

2018-10-05 17:55

reporter   ~0011932

Yes, I've reproduced everything you've observed. I think 0.18 solves this issue. Thank you.

wandererfan

2018-10-06 12:53

developer   ~0011943

Let's just leave this ticket here to remind me to fix the 0.0 display when AltDecimals is true.

wmayer

2018-10-11 20:08

administrator   ~0012005

https://github.com/FreeCAD/FreeCAD/commit/f6e9faa62c45a9fc8a9f977235abed139c31ab9a

Issue History

Date Modified Username Field Change
2018-10-04 18:18 chapatt New Issue
2018-10-04 18:18 chapatt File Added: techdraw_dimension_bug.FCStd
2018-10-04 18:18 chapatt File Added: techdraw_dimension_bug.png
2018-10-04 18:23 chapatt File Added: us-letter_landscape_plain.svg
2018-10-04 18:23 chapatt Note Added: 0011923
2018-10-05 12:35 wandererfan Note Added: 0011927
2018-10-05 12:37 wandererfan Assigned To => wandererfan
2018-10-05 12:37 wandererfan Status new => confirmed
2018-10-05 12:37 wandererfan Target Version => 0.18
2018-10-05 12:37 wandererfan Steps to Reproduce Updated View Revisions
2018-10-05 12:37 wandererfan Additional Information Updated View Revisions
2018-10-05 13:19 wandererfan Note Added: 0011931
2018-10-05 17:55 chapatt Note Added: 0011932
2018-10-06 12:53 wandererfan Note Added: 0011943
2018-10-11 20:08 wmayer Status confirmed => closed
2018-10-11 20:08 wmayer Resolution open => fixed
2018-10-11 20:08 wmayer Fixed in Version => 0.18
2018-10-11 20:08 wmayer Note Added: 0012005
2018-10-23 11:33 Kunda1 Tag Attached: units