View Issue Details

IDProjectCategoryView StatusLast Update
0003599PartDesignBugpublic2018-09-20 15:20
ReporternormandcAssigned Towmayer 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version0.18 
Target Version0.18Fixed in Version0.18 
Summary0003599: PartDesign Additive and Subtractive Pipe features don't allow changing sections after creation
DescriptionIn Constant or Multisection mode, once the Additive or Subtractive Pipe feature has been started, it is impossible to change the first selected section, as it does not appear in the Pipe parameters. In Multisection mode, once multiple sections have been selected and the feature completed by clicking OK, when editing the Pipe parameters again, the Multisection mode appears empty.
Steps To Reproduce[list=1]
[*]Open attached file PD_AddPipe_selection_issue3599_nc1.fcstd.
[*]Activate the Body.
[*]Select Sketch, then click on Additive Pipe.
[*]In the Pipe parameters, Sketch does not appear anywhere.
[*]Click on the "Object" button and in the 3D view, select the vertical edge (Sketch002).
[*]Under the "Section transformation" header, set the Transform mode to Multisection. Two buttons "Add/Remove Section" and a white field appear.
[*]Press "Add Section".
[*]Select the triangle in the 3D view (Sketch003).
[*]Press "Add Section" again and select the circle in the 3D view (Sketch001).
[*]Press OK to confirm and close.
[*]In the Model tree, double-click on AdditivePipe to edit it and open the Pipe parameters.
[*]Under the "Section transformation" header, the transform mode is set to Multisection, but the buttons and the list have disappeared.
[/list]
Additional InformationOS: Ubuntu 18.04.1 LTS
Word size of OS: 64-bit
Word size of FreeCAD: 64-bit
Version: 0.18.14727 (Git)
Build type: Release
Branch: master
Hash: c6df59969bfb3ae2027e2b47ddd559852f6e9a4e
Python version: 2.7.15rc1
Qt version: 4.8.7
Coin version: 4.0.0a
OCC version: 7.3.0
Locale: French/Canada (fr_CA)
TagsNo tags attached.

Relationships

duplicate of 0003598 closedwmayer The sections of a multi-section sweep cannot be edited in PartDesign 

Activities

normandc

2018-09-16 15:23

manager  

PD_AddPipe_selection_issue3599_nc1.fcstd (13,849 bytes)

wmayer

2018-09-20 13:18

administrator   ~0011797

https://github.com/FreeCAD/FreeCAD/commit/83c40da2a523134b6ef68495b2f031b004d1aacf
shows the sections when editing the pipe.

The initial section is stored in a separate property (Profile) and is not supposed to be listed in the Sections panel. If we want to edit the profile then it's best to implement this in an extra panel.

wmayer

2018-09-20 15:20

administrator   ~0011799

https://github.com/FreeCAD/FreeCAD/commit/14b8579a62a3619508267533a6b3a657dc55062d

Issue History

Date Modified Username Field Change
2018-09-16 15:21 normandc New Issue
2018-09-16 15:21 normandc File Added: PD_AddPipe_selection_issue3598_nc1.fcstd
2018-09-16 15:21 normandc File Deleted: PD_AddPipe_selection_issue3598_nc1.fcstd
2018-09-16 15:22 normandc Steps to Reproduce Updated View Revisions
2018-09-16 15:23 normandc File Added: PD_AddPipe_selection_issue3599_nc1.fcstd
2018-09-16 15:26 normandc Relationship added duplicate of 0003598
2018-09-20 11:04 wmayer Status new => confirmed
2018-09-20 13:18 wmayer Note Added: 0011797
2018-09-20 15:20 wmayer Assigned To => wmayer
2018-09-20 15:20 wmayer Status confirmed => closed
2018-09-20 15:20 wmayer Resolution open => fixed
2018-09-20 15:20 wmayer Fixed in Version => 0.18
2018-09-20 15:20 wmayer Note Added: 0011799