View Issue Details

IDProjectCategoryView StatusLast Update
0003588FreeCADBugpublic2018-09-13 22:08
ReporterchrisbAssigned Towmayer 
PrioritylowSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version0.18 
Target VersionFixed in Version0.18 
Summary0003588: The path to the Addons does not allow special characters
DescriptionIf a user has a special character in his name problems occur (at least on windows) with addons.
Corresponding [url=https://forum.freecadweb.org/viewtopic.php?p=255310#p255320]forum discussion[/url].
Tagsunicode

Relationships

related to 0002973 confirmed Path to FreeCAD.app can't contain unicode 

Activities

wmayer

2018-09-10 14:00

administrator   ~0011706

See also: https://forum.freecadweb.org/viewtopic.php?f=3&t=29160

wmayer

2018-09-13 14:05

administrator   ~0011727

https://github.com/FreeCAD/FreeCAD/commit/02eb4a6fa38731e443861fd9ffe78dabf5f631b8 fixes the creation of invalid directory names

wmayer

2018-09-13 19:44

administrator   ~0011729

https://github.com/FreeCAD/FreeCAD/commit/3386567d991f92eb660dd49330cb54e83ce5f102 fixes the init script where a utf-8 string (str) is used and thus led to some invalid path names.

Kunda1

2018-09-13 20:04

manager   ~0011730

Last edited: 2018-09-13 20:05

View 2 revisions

@wmayer is there a relationship with the following ticket?
#2973
#1672
and other tickets tagged: https://www.freecadweb.org/tracker/search.php?tag_string=unicode

wmayer

2018-09-13 22:05

administrator   ~0011732

https://github.com/FreeCAD/FreeCAD/commit/70cf68ab3d5644a35b7064728204e9421a871551

It turned out to be a Py2 limitation which raises a UnicodeEncodeError when trying to extend system path with special characters. With Py3 all this seems to work fine.
https://github.com/FreeCAD/FreeCAD/commit/62910898ddec24602ec5ddbe86fd20f646227dcf handles the UnicodeEncodeError and replaces the unsupported characters with "?"

wmayer

2018-09-13 22:07

administrator   ~0011733

0002973 is definitely related while 0001672 seems to be something different.

Issue History

Date Modified Username Field Change
2018-09-09 17:49 chrisb New Issue
2018-09-10 14:00 wmayer Note Added: 0011706
2018-09-13 14:05 wmayer Note Added: 0011727
2018-09-13 19:44 wmayer Note Added: 0011729
2018-09-13 20:04 Kunda1 Note Added: 0011730
2018-09-13 20:04 Kunda1 Tag Attached: unicode
2018-09-13 20:05 Kunda1 Note Edited: 0011730 View Revisions
2018-09-13 22:05 wmayer Note Added: 0011732
2018-09-13 22:07 wmayer Note Added: 0011733
2018-09-13 22:08 wmayer Relationship added related to 0002973
2018-09-13 22:08 wmayer Assigned To => wmayer
2018-09-13 22:08 wmayer Status new => closed
2018-09-13 22:08 wmayer Resolution open => fixed
2018-09-13 22:08 wmayer Fixed in Version => 0.18