View Issue Details

IDProjectCategoryView StatusLast Update
0000353FreeCADFeaturepublic2016-10-24 16:21
ReporteromarlakhdarAssigned ToJriegel 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version0.11 
Target VersionFixed in Version0.17 
Summary0000353: Graphical selection
DescriptionIt would be nice to have a graphical method of selection of a lot of pieces (rectangle box, draw a wire, a curve, or something like the brush selection in blender. example for brush selection: press key + left button while selecting. then just go above the different objects, it selects everything where the pointer is going.
TagsNo tags attached.

Relationships

parent of 0000462 closed Sketcher Sketcher: allow box selection 

Activities

Jriegel

2011-05-19 17:15

administrator   ~0000845

That brush selection is a cool idea! I will do that.

yorik

2011-10-16 14:24

administrator   ~0001170

I think ideally we could have both:

1) a "box" selection tool, that works the same way as the "box zoom" tool, except that it selects everything inside (there is the question: what must be inside to be selected? the bounding box center, or any vertex? Autocad solves that by having 2 modes)

2) a "brush" selection tool which, when activated, selects everything under the mouse cursor until the command stops.

The 1) might be easy to do, a big part can be borrowed from the box zoom tool... The only thing to do is to add to the selection all objects inside a certain area, I could try to do that, any clue on the best way to do it?

normandc

2011-10-16 20:27

manager   ~0001173

Box selection is standard on most GUI apps and operating systems and is IMHO the most intuitive method. Everybody who uses a computer knows to use it.

unauthenticated

2011-10-19 03:09

viewer   ~0001175

Just my two cents but As I've used a few CAD programs they may not be worthless:

You're supposed to have two methods of operation on the box select.
If you go from left to right it selects anything entirely in the box, and right to left selects anything with any part in the zoom box. Maybe I'm overstating the importance of this but it's worked that way in the CAD I've used so it almost seems like an industry standard.

normandc

2011-10-19 12:11

manager   ~0001176

AutoCAD works that way but this is not the case with all CAD apps.

In Solid Edge, you have a drop down menu with selection options: inside only, window crossing, outside window, etc.

wmayer

2012-04-28 13:51

administrator   ~0001977

Last edited: 2012-04-28 13:54

git show 106afe4
Box selection is implemented now. If the center of the bounding box is inside the rectangle an object will be selected. This seems to be the way how Blender does it.

yorik

2012-04-28 14:32

administrator   ~0001979

Amazing, Werner! Yes, it works exactly like blender. I'll make an icon for it. We could add this to the context menu too I think, it's a very useful tool... And a default shortcut, maybe, what about Shift+B? (Ctrl+B is for box zoom, it would make sense...)

esteewhy

2012-06-15 08:55

reporter   ~0002205

Last edited: 2012-06-15 10:21

This is so cool (thanks Yorik for suggesting to try 0.13) !

Does it make sense to let "box selection" be a default behavior when clicking outside any objects ? (Now clicking on empty space changes cursor to "hand" but does nothing else, which feels odd)

yorik

2012-06-15 11:01

administrator   ~0002206

Hm better not I think, it would break the functionality of other tools (sketcher and draft) that rely on clicking on no objects... Before adding this, a proper mechanism to decide when to trigger that or not should be implemented

Issue History

Date Modified Username Field Change
2011-05-18 20:49 omarlakhdar New Issue
2011-05-19 17:15 Jriegel Note Added: 0000845
2011-05-19 17:15 Jriegel Assigned To => Jriegel
2011-05-19 17:15 Jriegel Status new => acknowledged
2011-05-26 06:54 Jriegel Status acknowledged => assigned
2011-10-16 14:24 yorik Note Added: 0001170
2011-10-16 20:27 normandc Note Added: 0001173
2011-10-19 03:09 unauthenticated Note Added: 0001175
2011-10-19 12:11 normandc Note Added: 0001176
2011-11-01 20:33 yorik Relationship added parent of 0000462
2012-04-28 13:51 wmayer Note Added: 0001977
2012-04-28 13:54 wmayer Note Edited: 0001977
2012-04-28 14:32 yorik Note Added: 0001979
2012-06-15 08:55 esteewhy Note Added: 0002205
2012-06-15 10:21 esteewhy Note Edited: 0002205
2012-06-15 11:01 yorik Note Added: 0002206
2016-10-24 16:21 wmayer Changeset attached => FreeCAD Master master 761d684c
2016-10-24 16:21 wmayer Status assigned => closed
2016-10-24 16:21 wmayer Resolution open => fixed
2016-10-24 16:21 wmayer Fixed in Version => 0.17